2

I use the method described in this question to configure systemd to power off the laptop when the power button is pressed. (I.e., edit /etc/systemd/logind.conf.) This worked perfectly with OpenSUSE 13.1, but now that I'm running OpenSUSE LEAP 42.1, it doesn't work any more. When I press the power button, the system hibernates rather than shut down.

I have a sinking feeling that maybe gnome-settings-daemon is getting involved somehow. There's a gsettings schema named org.gnome.settings-daemon.plugins.power which contains a key named power-button-action, however the only permissible options are nothing, suspend or hibernate. But I don't want any of those options; I want shutdown!

I did try setting the active key to false to disable the power-management plugin. That had no effect on anything.

Is there any, any way I can convince systemd to show me some debug output, or see what the settings daemon is doing, or just generally make the power button turn the power off?!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.