In order to take advantage of all the features of systemd under Debian jessie I consulted many websites, but I have not found answers to my questions: How to set systemd as the default service manager under debian jessie? Do we get a stable system after performing this operation?

2 Answers 2


systemd is the default init system in Jessie, even when upgrading. If you want to enforce this, make sure the systemd-sysv package is installed; if that changes anything, reboot, and you'll see that the first process is /lib/systemd/systemd --system:

ps -f -p 1

Once that's done, you'll get full use of systemctl, journalctl etc. Since systemd is the officially-supported default in Jessie, you can expect the usual stability.

Other components of systemd are being introduced for Stretch, and are not available for Jessie; see for example systemd-coredump.

  • ""systemd-sysv/stable,stable,now 215-17+deb8u3 amd64 [installé]"" but I have more than 20 services disabled or masked using this command " systemctl list-unit-files "
    – GAD3R
    Feb 18, 2016 at 10:55

Actually, in jessie, if you have a look at the grub menu (assuming you use the default grub) you will have an advanced menu, under there you find several options to boot without systemd.

If you do not have this, you might have had a similar issue I encountered, I upgraded from wheezie to jessie and the kernel entry in grub did not get updated, which meant that the system started with sysvinit or whatever it is called instead of systemd.

I simply uninstalled some old kernels I did no longer want and ran sudo update-grub to update grub menu.

Watch out, make 100% sure that the boot entry in grub matches the files in /boot.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .