0

I'm doing a test install of a CentOS 7 VM with a Kickstart file in text mode, but after a while the installation hangs on this screen (this is the main terminal, VT1):

enter image description here

Here's the content of VT4 (as seen via Ctrl+Alt+F4):

enter image description here

The Kickstart file used is this one:

#version=RHEL7
# System authorization information
auth --enableshadow --passalgo=sha512

# Use CDROM installation media
cdrom
# Use graphical install
install
text
# Run the Setup Agent on first boot
firstboot --enable
ignoredisk --only-use=vda
# Keyboard layouts
keyboard --vckeymap=ch --xlayouts='ch'
# System language
lang en_US.UTF-8

# Network information
network  --bootproto=static --device=eth0 --gateway=192.168.77.1 --ip=192.168.77.222 --nameserver=8.8.8.8 --netmask=255.255.255.0 --ipv6=auto --activate
network  --hostname=localhost.localdomain
# Root password
rootpw --iscrypted $6$CmjyBHZ.4piG.00J$JESV6h1LUaMxB2n2sJEkjd97GobnYIdAYPJmQtlKQMpiaPPKMpAD.4z3RPb9KxUvIg8SlFVC2KhG..2.6ivwI/
# System timezone
timezone America/Santiago --isUtc --nontp
# X Window System configuration information
xconfig  --startxonboot
# System bootloader configuration
bootloader --append=" crashkernel=auto" --location=mbr --boot-drive=vda
autopart --type=lvm
# Partition clearing information
clearpart --none --initlabel

%packages
@base
@core

%end

%addon com_redhat_kdump --enable --reserve-mb='auto'

%end

and the VM is created via this command:

virt-install --virt-type=kvm --name=centos7test6 --disk path=/var/lib/libvirt/images/centos7test6.img,size=6 --initrd-inject=/root/kickstart-tests/test.ks --ram=1024 --vcpus=1 --os-variant=rhel7 --accelerate --graphics vnc -v -l http://mirror.centos.org/centos/7/os/x86_64/ --network bridge:virbr0 --extra-args="console=tty0 console=ttyS0,115200 ks=file:/test.ks"

A graphical install works fine, but I want to test a text install to afterwards customize the %pre- and %post-install sections. What could be done to troubleshoot this?

  • I don't have a solution, but it appears that selinux is preventing some activity at the end there – Jeff Schaller Feb 17 '16 at 15:57
  • I noticed that too but the GUI install works perfectly. – dr01 Feb 17 '16 at 16:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.