14

I installed Netbeans on my Ubuntu 11.10 machine. I used the combined method, so Netbeans and JDK are installed from a single file. However, now that it's installed I can't figure out how to start Netbeans. If I try to reinstall it says that Netbeans is already installed, but if I look in /usr/share/netbeans there are the installation files but nothing else. How do I run Netbeans?

2
  • What is Logitech? Commented Dec 9, 2011 at 4:26
  • I tried editing this, but I couldn't figure out your second paragraph at all Commented Dec 9, 2011 at 4:47

7 Answers 7

16

Look for it:

sudo find / -name netbeans 2> /dev/null

If you get a location, it's installed. If not, I would suggest trying to use apt to install instead of the one-file method.

1
  • 1
    You made my day.
    – quantme
    Commented Dec 13, 2012 at 20:57
10

looks like the netbeans installer forgot to add a symlink

ln -s /usr/local/netbeans-7.0.1/bin/netbeans /usr/local/bin/netbeans

It would have made life easier for users if the install script did this.

(don't forget to update symlink when you upgrade netbeans version)

1
cd /usr/local/netbeansx.x/bin
./netbeans
1

Java before Netbeans...

#!/bin/sh

#Delete the line below if you only want the "open" JDK & JRE
sudo apt-get install openjdk-7-jdk openjdk-7-jre;

#Makes the /usr/lib/jvm in case...
sudo mkdir -p /usr/lib/jvm

#Clean out /tmp...
sudo rm -rf /tmp/*
cd /tmp

#Update this line to reflect newer versions of JDK...
wget http://download.oracle.com/otn-pub/java/jdk/7u1-b08/jdk-7u1-linux-i586.tar.gz;
tar -xvf ./*gz;

#Move it to where it can be found...
sudo mv /tmp/jdk1.7.* /usr/lib/jvm/;

#Add the new Java to the bin 
sudo update-alternatives --install /usr/bin/java java /usr/lib/jvm/jdk1.7.0_01/jre/bin/java 3;

#User chooses
sudo update-alternatives --config java;

exit 0;

Netbeans...

#!/bin/sh
# @author Yucca Nel
# Update as needed for newer Netbeans releases :D

#!/bin/sh

#Clean out /tmp...
sudo rm -rf /tmp/*;
cd /tmp;

# Update this line to reflect newer versions of Netbeans or replace 
# 'javase with 'javaee' or add jee manually via Netbeans 'plugins as needed.
wget http://download.netbeans.org/netbeans/7.0.1/final/bundles/netbeans-7.0.1-ml-javase-linux.sh;
sh /tmp/*sh;

# Add Netbeans launcher to your PATH. Doing so allows you to run 
# 'netbeans' command from the terminal
sudo ln -s ~/netbeans-7.0.1/bin/netbeans /usr/local/bin/;

# If you use VirtualBox , you can share your projects between 
# Host and guest. Name of shared folder must match 'NetBeansProjects' 
# Remove this if you don't need...
sudo mkdir ~/NetBeansProjects;
sudo mount -t vboxsf NetBeansProjects ~/NetBeansProjects;
exit 0;
1

Oracle had stop supporting netbeans and this project is being taken by Apache.
Executive which command to locate where is netbeans installed on your system.

which netbeans

this would give path

/usr/bin/netbeans

If you now open this file in some editor or just cat the output of this file.

cat /usr/bin/netbeans

this would show that (as of today) apache netbeans is installed in

/usr/lib/apache-netbeans/

whereas the config files are in

/home/$USER/.netbeans
0

You're running Unity in 11.10 by default, if you press the Meta (windows key), and type in netbeans,

You should be able to see few entries related to netbeans.

0

you use the which command to find out location of any application (binary) installed.

e.g.

$which netbeans

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .