1

I have seen this question asked on many forums across the internet and have created this question as a place for people to explain their success or failure at creating this set-up.

4

Short Answer:

At present there are many obstacles to getting tablets of this kind to run a linux OS. Any attempt is likely to result in a Buggy install. However it technically can be done and I expect this to become easier in the near future.

Long Answer:

I have an HP Stream 7 Tablet computer (shipped with windows 8.1). I have been trying for the last year to get a Linux OS running on it.

The tablet has a 32bit UEFI and a 64bit processor. This poses certain difficulties when installing linux. edit: Many of these problems can now be solved by doing a 'manual' install.

The following thread on the ubuntu forums led me to believe that it was possible to install ubuntu mate on this tablet using components from a small one-man project called Fedlet.

The Ubuntu forum thread explaining linux install on HP Stream 7

*Unfortunately I hit a problem where the ubiquity installer would 'hang' when I got to the 'Partition Drives' step. (the OS had booted from a USB drive).

Eventually I isolated the problem and established that this was because the system tried to read one of several 4MB partitions on the SSD called a Replay Protected Memory Block (RPMB). This RPMB is used by windows to store the DRM keys needed to run the windows OS. Files in the RPMB format can't be deleted or otherwise altered without a decryption key. They also cannot be mounted without the key.

When Linux tries to mount this RPMB partition the system hangs. Most Linux distributions have a bug already registered saying that this is the case. *edit: This has been fixed in more recent kernels.

The one distribution that does not have this bug is Debian Multi-arch. This OS can be installed on the tablet but the kernel provided does not support touch screens. Once I compiled my own kernel the tablet worked with gnome and touch-screen! However the touch-screen was buggy, registering several clicks when I touched it and I still have no wifi as this is not supported at present by the linux kernel (at least to my knowledge). I will try to compile a wifi driver in the near future.

A Very Rough Guide to Installing Debian Multi-arch on Baytrail Tablets.

  1. First back up your windows install to a USB drive.
  2. Make a Debian Multi-Arch Install USB drive.
  3. Look up the Touchscreen and Wifi Device that your Tablet has and Compile a Kernel with the appropriate kernel drivers included. I recommend a more recent kernel
  4. Disable Secure boot in the BIOS of the Tablet.
  5. Resize the Windows Partition to make room for the Linux install. Only necessary if you wish to duel boot with windows.
  6. Boot the USB drive and install the OS using the 64 bit graphical installer. chances are your wifi device and touch-screen won't work at this point
  7. reboot the tablet and select your new debian install from the boot options.
  8. Once debian has booted install your new custom kernel from a usb stick.
  9. Finally connect to the internet and install GNOME Desktop.

A Very Rough Guide to Installing Ubuntu 16.04 32bit on Baytrail Tablets.

1a) First back up your windows install to a USB drive. Disable secure boot.

1) take a USB disk and partition it to have a two partitions. Place the efi files from fedlet into the first partition and copy the 32bit ubuntu server 16.04 iso into the second.

2) edit the grub file in the first partition (the one with the efi files) to point to the second partitions kernel files. The grub boot entry should look something like this:

    menuentry "ubuntu server usb" {
set root=(hd0,gpt1)
    linuxefi    (hd0,gpt1)/install/vmlinuz  boot=install    
    initrdefi   (hd0,gpt1)/install/initrd.gz
}

Where (hd0,gpt1) is the partition containing the copy of the ubuntu server iso.

3) Boot from the disk and select the menu entry corresponding You will need a keyboard and an internet adaptor (I used a usb to Ethernet adaptor from maplin)

4) install the system using the onscreen dialogues.

5) reboot (without the USB) and select drop to root shell.

6) configure ifupdown to connect to the internet.

7) apt-get install ubuntu-desktop or gnome-desktop or whatever it is you plan to use.

8) reboot and you should have a working tablet.

9) drivers for the wifi can be found here Hadess wifi driver

0

Yes, some tablets dont have as much trouble as others, I believe it really comes down to installing drivers.

To get past EFI boot I used the bootia32 file from a 'fedlet.iso' in /EFI/BOOT you can find plenty on how ti

then I had managed to install arch using this guys tutorial: https://www.youtube.com/watch?v=MMkST5IjSjY

I downloaded and added patches from a /hadess/rtl8723 repo however I was still not managing to find the hardware using commands like lspci and hwls.

I have found a guide for another kind of baytrail tablet that found a way a to activate the hardware at boot: https://www.reddit.com/r/LinuxActionShow/comments/3dtsz2/archlinux_up_and_running_on_the_acer_iconia_tab_8w/

but this does not apply to my drivers yet, im still to find anything on activating the hardware on boot.

I came across this article among a few others which suggests that the issue may be resolved only when there is a will to fix it.

  • What tablet was this? How did you get around the RPMB problem? – Huw Evans Jun 17 '16 at 17:18
  • hp stream 7, rpbm? – Jethro Devøn Jun 30 '16 at 18:22
  • Ok I have the same tablet. I'll try to replicate your methods when I get the chance. RPMB stands for replay protected memory block. I describe the problems it causes in my own answer. It may be this has been fixed. – Huw Evans Jul 1 '16 at 10:48
  • 1
    I checked an the RPMB problem has been fixed. I was able to install ubuntu linux from the server install with a little difficulty. – Huw Evans Jul 18 '16 at 10:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.