0

I installed Mysql server 5.7.9 on RHEL 6.5 using mysql57-community-release-el6-7.noarch.rpm Repo. And installation was successfull but when i try to start it up and gives errors. And from /var/log/mysqld.log i get these logs

> 2016-02-16T08:16:55.473839Z 0 [Note] InnoDB: PUNCH HOLE support
> available 2016-02-16T08:16:55.473945Z 0 [Note] InnoDB: Mutexes and
> rw_locks use GCC atomic builtins 2016-02-16T08:16:55.473983Z 0 [Note]
> InnoDB: Uses event mutexes 2016-02-16T08:16:55.474011Z 0 [Note]
> InnoDB: GCC builtin __sync_synchronize() is used for memory barrier
> 2016-02-16T08:16:55.474038Z 0 [Note] InnoDB: Compressed tables use
> zlib 1.2.3 2016-02-16T08:16:55.474062Z 0 [Note] InnoDB: Using Linux
> native AIO 2016-02-16T08:16:55.474908Z 0 [Note] InnoDB: Number of
> pools: 1 2016-02-16T08:16:55.475257Z 0 [Note] InnoDB: Not using CPU
> crc32 instructions mysqld: Can't create/write to file '/tmp/ibUFqzVe'
> (Errcode: 13 - Permission denied) 2016-02-16T08:16:55.475430Z 0
> [ERROR] InnoDB: Unable to create temporary file; errno: 13
> 2016-02-16T08:16:55.475460Z 0 [ERROR] InnoDB: Plugin initialization
> aborted with error Generic error 2016-02-16T08:16:55.475490Z 0 [ERROR]
> Plugin 'InnoDB' init function returned error.
> 2016-02-16T08:16:55.475515Z 0 [ERROR] Plugin 'InnoDB' registration as
> a STORAGE ENGINE failed. 2016-02-16T08:16:55.475536Z 0 [ERROR] Failed
> to initialize plugins. 2016-02-16T08:16:55.475557Z 0 [ERROR] Aborting
> 
> 2016-02-16T08:16:55.475583Z 0 [Note] Binlog end
> 2016-02-16T08:16:55.475695Z 0 [Note] Shutting down plugin
> 'keyring_file' 2016-02-16T08:16:55.476442Z 0 [Note] /usr/sbin/mysqld:
> Shutdown complete
> 
> 2016-02-16T08:16:55.502968Z mysqld_safe mysqld from pid file
> /var/run/mysqld/mysqld.pid ended

Any advice what this error is talking about ......

  • And what do you think the problem is? – techraf Feb 16 '16 at 9:14
  • "RHEL 6.5 using mysql57-community-release-el7-7.noarch.rpm" ... read it twice (or more) and try to find the first problem :) – stderr Feb 16 '16 at 9:29
  • Oh it was typo error actually it is mysql57-community-release-el6-7.noarch.rpm – OmiPenguin Feb 16 '16 at 9:36
1

MySQL server is not able to access your /tmp directory, to write and create temporary files. Make sure /tmp directory is owned by root user and sticky bit is set on /tmp directory. Type the following commands to fix this error. You must be login as root user and type:

chown root:root /tmp

chmod 1777 /tmp

test it

/etc/init.d/mysqld start

  • Yes dear directory was available to root but sticky bit was not set and after setting sticky bit im able to start the service ...... – OmiPenguin Feb 16 '16 at 11:40
  • changing system dir permissions is the worst idea ever :) And if /tmp is set badly, it means the system is not ok. – stderr Feb 16 '16 at 11:42
1
> [ERROR] InnoDB: Unable to create temporary file; errno: 13

This line looks like a problem there. Try to check if /tmp dir exists (it should) and is available for mysql user (or the user you use). You can try to use a different path with --tmpdir or an option within config, more info at docs).

There can be problem with SELinux too (if it is in Enforcing mode). Check your audit log (eg. with ausearch -ts today -m avc | audit2allow) if /tmp dir isn't blocked for mysql. For tests you can disable SELinux with setenforce 0.

  • ausearch is for people who have auditing enabled, right? – Rui F Ribeiro Feb 16 '16 at 11:33
  • 1
    sure, ausearch is effective only when your selinux is in enforcing or permissive mode. – stderr Feb 16 '16 at 11:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.