1

am using avahi on a freescale imx6 board with a custom linux system (build by buildroot).

So I use avahi for address allocation (eth0:avahi) and hostname resolution. My freescale imx6 board also uses an other interface with a "static" network address used in an other subnet mask (eth0).

I have also created an other interface eth0:0 with an other address (this third ethernet address is only created in order to understand my problem)

ifconfig of my freescale imx6 board :

eth0      Link encap:Ethernet  HWaddr 1E:ED:19:27:1A:B3 
          inet addr:192.168.1.212  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3037485 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12312042 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:213265042 (203.3 MiB)  TX bytes:1150418317 (1.0 GiB)

eth0:0    Link encap:Ethernet  HWaddr 1E:ED:19:27:1A:B3 
          inet addr:134.124.45.23  Bcast:134.124.255.255  Mask:255.255.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

eth0:avahi Link encap:Ethernet  HWaddr 1E:ED:19:27:1A:B3 
          inet addr:169.254.6.124  Bcast:169.254.255.255  Mask:255.255.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:484 errors:0 dropped:0 overruns:0 frame:0
          TX packets:484 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:32284 (31.5 KiB)  TX bytes:32284 (31.5 KiB)

For my test, i use a pc connected with my freescale imx6 board. I launch command "avahi-browse -a -c -r -v " from this pc.

When I launch avahi-browes from my pc, I can see the hostname (name.local) of the freescale imx6 board but it is associated with the address of interface eth0:0 and not eth0:avahi. When i remove the interface eth0:0, the hostname of the freescale imx6 board is associated with eth0.

From my pc, I can ping freescale imx6 board using eth0, eth0:avahi address and eth0:0 (when it's activated)

My problem : I want, when i launch command "avahi-browse -a -c -r -v", my freescale imx6 board to return the address associated with eth0:avahi because, currently, my freescale imx6 board returns the last interface configurated (in my exemple, eth0:0) Do you know how to do that ?

Thank you for your answers,

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.