0

My mother has a radio that can play MP3s on a USB key. I noticed something strange. When I format it with diskpart from Windows 8.1 my mother's radio has no problems playing the MP3s on a USB key, but if I do the same with fdisk, the radio just says that there are no files on the USB key.

So, this is what I did to make sure, I was not just imagining things:

  1. First, I did a quick delete of all the files in the USB key with:

    sudo dd if=/dev/zero of=/dev/sdb bs=4M count=1

    Well, that deletes the MBR, partition table thoroughly. (I know I do not need to delete 4M to delete everything, but I was not sure about gpt and stuff.)

  2. I formatted the USB key with Windows diskpart

    diskpart
    list disk
    select disk 1
    clean
    create partition primary
    select partition 1
    active
    format fs=fat32 quick
    exit

    It works perfectly on my mother's radio!

  3. Now I format it with fdisk after deleting everything like above with dd:

    sudo fdisk /dev/sdb
    n
    p
    (return 3x)
    a
    w
    sudo mkfs.vfat -F 32 /dev/sdb1
    

    Now for some reason it doesn't work!

Here is the information gparted gives me when I format the USB key with fdisk: device information enter image description here

And here is the information when formatted with diskpart:

enter image description here enter image description here

Please tell me if there is a way to make the USB key work on my mother's radio without having to boot up Windows all the time. Thanks!

  • Are you using gparted live-cd or Linux machine? – GAD3R Feb 15 '16 at 20:42
  • @GAD3R: I installed gparted in lubuntu 15.10. I am using the LXDE desktop, not lubuntu. My question was already answered, though, but thanks! – mkdrive2 Feb 15 '16 at 20:46
1

You didn't set the partition type in fdisk. Most modern operating systems (including Linux itself) ignore it anyway and just look at the file system. But certain embedded devices don't recognize the file system if the partition type isn't set properly.

While partitioning your USB device, type tin fdisk and set the partition type to c (W95 FAT32 LBA).

  • Hey, you were right!! It was not even necessary to set the bootable flag to make it work! – mkdrive2 Feb 15 '16 at 20:37
  • One thing, though, that is still troubling me. When partitioning with diskpart it worked without the lba flag, but when I set the type to c, there is an lba flag in gparted. Do you know why? – mkdrive2 Feb 15 '16 at 20:40
  • It still works after removing the lba flag in gparted, though, so, well, nevermind. – mkdrive2 Feb 15 '16 at 20:42
  • 1
    I don't think it really matters. If you don't want it, set the partition type to b which is WIN95 FAT32 without LBA (which is probably what Windows did). – Janek Bevendorff Feb 15 '16 at 20:45
  • Oh, right, there was that option, too! Thanks! – mkdrive2 Feb 15 '16 at 20:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.