0

So, I had a WiFi connection "working" with WPA Supplicant. That took quite a bit of doing, and wasn't optimal. The networks would drop out every few minutes. I wrote a script which would reset the connection, but I still had 20 seconds of downtime every few minutes.

I had a spare router lying around, so I flashed the firmware to DD-WRT and configured it as a repeater bridge. I know this is working because I have successfully connected to the internet with it both wirelessly and through the ethernet ports.

I did something stupid and deleted WPA Supplicant before I even connected with the wired connection. I then changed my /etc/network/interfaces file to reflect the new settings.

I've tried several configurations in the interfaces file, but the current one is...

auto eth0
     iface eth0 inet dhcp

Suffice to say I cannot acquire a connection. I then ran ifconfig. The result showed only the lo. I then ran ifconfig -a and saw eth0.

Thinking it was a driver problem, I downloaded the 82562Ez Intel LAN drivers. I unzipped the tar-ball and attempted an install. The drivers would not install because they were intended for 2.x.x kernels, while mine is 3.16.0. (I'm currently running Debian Jessie.)

I then tried multiple interface configurations. I cannot get anything to work.

I see an entry when running lspci for...

Ethernet controller: Intel Corporation 82562EZ 10/100 Ethernet Controller (rev 01)

I'm fairly new to Linux, especially command line Linux, so if I need to provide more information I would be happy to.

What could the problem be? How do I connect to my network?

EDIT

Using lsmod I found a module named e100. Running modinfo e100 I found that it was indeed the Intel driver for my onboard ethernet port.

  • What happens if you do dhclient eth0 and then echo $? ? – schaiba Feb 15 '16 at 6:31
  • @schaiba It prints out "0". – Allenph Feb 15 '16 at 6:34
0

I have found the problem and the solution. WPA_Supplicant was getting greedy with my network configuration even after deleting it's configuration file and changing the interface settings.

sudo apt-get --purge remove wpasupplicant and a reboot solved my problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.