2

I have a centos VM running via KVM on my Debian laptop.

This is what I see when I run systemd-cgtop: enter image description here

I know I have a user,system,and machine slice, but I'm only seeing data from the machine slice.

I'm running chrome and youtube so I know stuff is going on in the user slice, but I don't see the user slice at all.

How can I get my other slices to report utilization in cgtop?

3

A possible reason is that you have not enabled the CPUAccounting for the system slice.

Check if /etc/systemd/system.conf is defined with DefaultCPUAccounting=yes or define CPUAccounting=yes in system.slice.

  • I have the same issue on OpenSUSE. DefaultCPUAccounting didn't help. Setting CPUAccounting=yes in all slices indeed made systemd-cgtop report slices load but still didn't report any automatic sub slices nor individual services. – Lapsio Aug 18 '16 at 17:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.