2

i have recently bought a raspberry pi so i can learn "linux" and other stuff with it, i loaded it with noobs and add raspbian and ubuntu mate (this port from xda forums) and everything works well. than i decided to try and use vnc to have my phone (Galaxy s3) be used as the display. i tried to follow this tutorial but after i boot the pi and run ifconfig (both when the phone is and isn't connected) i can't see usb0

so after further investigation when i run ifup usb0 i get "cannot find device usb0", does anyone no a solution?

note (i have tried this with ubuntu mate and have yet to try with raspbian)

0

The Linux distro the author of your document used refers to the network interface of the Raspberry Pi as usb0. The Raspberry Pi uses a USB based Ethernet adapter, but the naming convention is up to the distro developers and therefore can change between various flavours of Linux. The distro on my Pi (Raspbian) has this as eth0.

Try running ip link to see what devices you have. On mine, I get:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT qlen 1000
    link/ether b8:27:eb:b7:1a:aa brd ff:ff:ff:ff:ff:ff

This shows the loopback device lo and my Ethernet device eth0. If the ip command isn't available on your distro, then try running ifconfig instead.

Whichever name you find for your Ethernet device, you should use that instead of usb0 in the document.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.