I just updated from Ubuntu 14.04 to 16.04 and it was a bumpy ride with damaged drivers along the way, probably because of the fact that 14.04 was missing two important drivers that 16.04 did have.

Now after restoring my drivers and a lot of systems I have a problem: whenever I create a new Java class in NetBeans or Eclipse my system hangs and the IDE becomes unresponsive. I can create empty files just fine and I can load and run files already created but I can no longer create new classes. I have correctly installed Java. I have also tried purge and install NetBeans and download and use a new version of Eclipse (Mars 1)

Any idea what's wrong? Or how to get useful information for debugging/solving the issue?

  • Do you mean Ubuntu 15.04 or 16.04? Ubuntu 16.04 is not scheduled for release until 21 April 2016, which is about 9 weeks from now. omgubuntu.co.uk/2015/10/…
    – Fred
    Feb 13 '16 at 1:02
  • No 14.04 dev build.
    – Thijser
    Feb 13 '16 at 7:19
  • could this be related to bugs.launchpad.net/ubuntu/+source/java-common/+bug/1552764 ? I experience similar problems, and launchpad should be the right place to get it fixed by Ubuntu. Best regards, mifritscher Mar 5 '16 at 13:06
  • Could be, however I'm not sure what I did but after reinstalling half my system (desktop manager, graphics driver, apt and a few others) it started working again.
    – Thijser
    Mar 6 '16 at 21:52

For me setting the environment variable SWT_GTK3=0 worked. This is described in http://www.eclipse.org/swt/faq.php#gtkstartup.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.