2

I updated the system 2 days ago and now realised a startx systemd script failed to start. This is seems to be caused by the fact that Arch booted into tty1 by default. Switching to tty7 and restarting the startx systemd script works fine presumably because systemd script specifies tty7. Running just "startx" command results in the following error where it worked 2 days before:

(==) Log file: "/home/XXXXX/.local/share/xorg/Xorg.0.log", Time: Wed Feb 10 19:13:22 2016
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE)
Fatal server error:
(EE) parse_vt_settings: Cannot open /dev/tty0 (No such file or directory)
(EE)
(EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
(EE) Please also check the log file at "/home/XXXXX/.local/share/xorg/Xorg.0.log" for additional information.
(EE)
(EE) Server terminated with error (1). Closing log file.
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error
Couldn't get a file descriptor referring to the console

Here is the relevant snippet from systemd script:

TTYPath=/dev/tty7
ExecStart = /usr/bin/xinit /usr/bin/dbus-launch --exit-with-session /usr/bin/kodi-standalone -- :0 -nolisten tcp vt7
Restart = on-abort
StandardInput = tty

Normally the system boots into tty7 and GUI apps have no problem starting whether tty7 is specified or not, now startx attemts to use tty0 by default which seems to be non-existent. Was there a change in default behaviour? How can this be resolved?

  • How are you calling startx in the script? startx -- vt7? – muru Feb 12 '16 at 12:44
  • See edit. startx would start before recently with just "startx" from command line. – DominicM Feb 12 '16 at 12:49
  • This command would also work for the same app from systemd script "startx /usr/bin/kodi --standalone" – DominicM Feb 12 '16 at 12:50
1

I finally figured out the cause. I have edited Xwrapper.config which is needed for Kodi and have changed it since then to test it's requirement. An update must have changed something that made it required again.

sudo nano /etc/X11/Xwrapper.config

allowed_users=anybody
needs_root_rights = yes // no value caused issues

sudo startx still worked with no option though running it and exiting would make it impossible to switch to tty7.

I still don't know why it's required since my understanding was that startx did not require root permissions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.