0

I'm using putty in Centos in order to connect to another Centos server. The copy/paste functions of putty in Centos is weird! I tried to select text to copy text and right click to paste it. The copy is ok but the past doesn't work(I've tried middle mouse button too). I googled it and found that pasting does work with Ctrl+Shift+Insert. That works fine.

I've tried to paste a text which i copied in putty before in another program(for example in the web browser) but the clipboard is the same as before copying in putty.

I'm wondering, how can I copy some text in putty and paste it in a browser in Centos.

  • Why putty and not the native ssh clients? – Rui F Ribeiro Feb 12 '16 at 13:11
  • I can't use native ssh client, because I use a key file for connection(ppk), and I get this error with native ssh client: Permissions 0644 for 'testdev.ppk' are too open. It is required that your private key files are NOT accessible by others. This private key will be ignored. bad permissions: ignore key: testdev.ppk Permission denied (publickey,gssapi-keyex,gssapi-with-mic). – Ehsan Feb 12 '16 at 15:05
  • techtuts.info/2014/06/convert-ppk-id_rsa-linux convert it to id_rsa following the tutorial; then mkdir ~/.ssh ; mv id_rsa ~./ssh ; chmod 700 ~/.ssh ; chmod 600 ~/.ssh/id_rsa ; then you will be able to use the native ssh client. – Rui F Ribeiro Feb 12 '16 at 15:38
  • I've installed putty from rpm and I'm using centos: sudo yum install putty Loaded plugins: fastestmirror, langpacks Loading mirror speeds from cached hostfile * base: ftp.plusline.de * epel: mirror.imt-systems.com * extras: wftp.tu-chemnitz.de * updates: ftp.plusline.de Nothing to do and pyttygen testdev.ppk -O private-openssh -o id_rsa pyttygen: command not found... – Ehsan Feb 12 '16 at 16:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.