3

I am running Gentoo Hardened using kernel version 4.1.7-hardened-r1. When I first set up my system I was able to emerge Chromium without a hitch. However, I recently issued emerge --sync followed by a world update, and now Chromium will not update with this error.

rockshooter /etc/portage # emerge -aNDu --with-bdeps=y @world
These are the packages that would be merged:

Calculating dependencies... done!

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-libs/libxml2:2

  (dev-libs/libxml2-2.9.2-r4:2/2::gentoo, ebuild scheduled for merge) conflicts with
    dev-libs/libxml2:=[icu] required by (www-client/chromium-48.0.2564.82:0/0::gentoo, installed)
                       ^^^
    dev-libs/libxml2:2/2=[icu] required by (www-client/chromium-48.0.2564.82:0/0::gentoo, installed)
                          ^^^


Nothing to merge; quitting.

Prior to setting up Gentoo I made a test on a VM and got that common error where Chromium, libxml, qt-webkit and ICU tend to not play well on Portage, so I thought this was just going to be a matter of globally setting the icu USE flag. However... it turns out that not only I'm not seeing qt-webkit being part of the conflict, but I also do have USE="icu" set on my make.conf.

CFLAGS="-O2 -pipe -march=native"
CXXFLAGS="${CFLAGS}"

ACCEPT_LICENSE="-* @FREE CC-Sampling-Plus-1.0"
ACCEPT_KEYWORDS="amd64"

FEATURES="webrsync-gpg ccache parallel-fetch userfetch"
PORTAGE_GPG_DIR="/var/lib/gentoo/gkeys/keyrings/gentoo/release"
CCACHE_SIZE="4G"

CHOST="x86_64-pc-linux-gnu"
CPU_FLAGS_X86="aes avx fma3 fma4 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 xop"

USE="${CPU_FLAGS_X86} gif jpeg png tiff apng java alsa libressl icu"
LINGUAS="en es es_LA fr de"

Now I'm stumped because I have no idea of how to fix this update blocker. I do have USE="icu" set on make.conf and I'm not seeing qt-webkit being part of the conflict -- any idea of what's going on?

  • Please add the output of emerge -av dev-libs/libxml2 – eyoung100 Feb 12 '16 at 21:10
  • I ran into the same issue just now and solved by adding the icu global use flag to my make.conf, and then searching for libxml in package.use and removing one entry that had added "python" to a specific version of libxml2. after that I tried to update world again with --autounmask-write and the conflict was gone. I'm not quite sure myself what exactly caused that package.use entry to create this blocker. – Francesco Noferi Mar 16 '16 at 13:53
0

Problem solved. If I remember correctly, I think I solved it by running emerge --depclean, revdep-rebuild and then emerging back the packages that emerge uninstalled (because two of them were the radeon display drivers and the evdev X input driver).

0

For apparent blockages when trying to emerge Chromium and KDE stuff, see also: https://wiki.gentoo.org/wiki/Qt/FAQ#qtwebkit_vs_chromium_block_caused_by_icu

That is, either enable or disable both these USE flags for qtwebkit:

# In package.use:
dev-qt/qtwebkit gstreamer icu
# OR
dev-qt/qtwebkit -gstreamer -icu

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.