I'm changing my CPU frequency because of noisy fan.

I used sudo cpufreq-selector -g powersave for this purpose, but I replaced my Linux system Xubuntu with Lubuntu because it utilizes better resources. My version is 11.10 and I'm not using Gnome nor KDE nor XFCE nor LXDE (only Xmonad).

There is something wrong with cpufreq-selector

$ cpufreq-selector

Failed to acquire org.gnome.CPUFreqSelector: Connection ":1.35" is not allowed to own the service "org.gnome.CPUFreqSelector" due to security policies in the configuration file

cpufreq-info shows

$ cpufreq-info Report errors and bugs to cpufreq@vger.kernel.org, please.
analyzing CPU 0:
driver: acpi-cpufreq
CPUs which run at the same hardware frequency: 0
CPUs which need to have their frequency coordinated by software: 0
maximum transition latency: 10.0 us.
hardware limits: 600 MHz - 1.60 GHz
available frequency steps: 1.60 GHz, 1.40 GHz, 1.20 GHz, 800 MHz, 600 MHz
available cpufreq governors: conservative, ondemand, userspace, powersave,
performance current policy: frequency should be within 1.60 GHz and 1.60 GHz.
The governor "ondemand" may decide which speed to use
within this range.
current CPU frequency is 1.60 GHz.
cpufreq stats: 1.60 GHz:98.40%, 1.40 GHz:0.02%, 1.20 GHz:1.58%, 800
MHz:0.01%, 600 MHz:0.00% (38)

I also tried this guide because my processor is the same (only the frequency is 1.6 instead of 1.73). I'm not sure if something happened after

sudo modprobe speedstep_centrino command

Could you help me to figure out what's wrong here and why I can't slow the frequency down?

  • the same happens on Ubuntu 18.04 LTS.... – razor Apr 16 '19 at 7:37

org.gnome.CPUFreqSelector sounds like DBus but googling revealed it could be a PolicyKit issue. Maybe this helps, granting the applet CPUFreq changes.

I think you don't need the cpufreq-selector tool, you could just use cpufreq-set directly (maybe with sudo, I'm not sure). (Or the cpupowerutils frontend, alive here)

(Edit to match your updated question)

  • modprobe not outputting anything indicates that everything went fine (try echo $? after the modprobe, it should be 0 indicating success; also dmesg could contain something; also lsmod's output should be different afterwards, indicating that the module is loaded).
  • Have you tried modprobeing an actual governor, i.e., modprobe cpufreq_powersave (after modprobeing your speedstep_centrino)? (The respective cpufreq-set -g powersave should work then.)
| improve this answer | |
  • 1) There is a problem to switch to the directory polkit-1 2) cpufreq-set 3) cpupowerutils – xralf Dec 6 '11 at 11:10
  • Sorry, I don't know any further. Best try to fix the polkit issue, I'd have guessed the cpufreq-set doesn't honor it, but maybe it does after all... (How about cpufreq-set -g powersave and lsmod | grep cpufreq to check if the modules are loaded?) – sr_ Dec 6 '11 at 11:17
  • 1) cpufreq-set -g powersave outputs the same error 2) lsmod | grep cpufreq founds nothing – xralf Dec 6 '11 at 11:34
  • 2) That could be the problem. Try modprobe cpufreq_userspace (or cpufreq_powersave) and cpufreq-set -u 1.20GHz (or -g powersave) afterwards (more information about the needed modules, maybe the one I mentioned is not enough) – sr_ Dec 6 '11 at 11:38
  • When running modprobe I can't see any output and nothing changed. I also edited the question with guide I tried to apply and where it stuck. – xralf Dec 6 '11 at 12:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.