I've been having problems with my wifi connection (rtl8821ae driver). I can stay connected for hours (as long as 6 hours) and then sometimes it just crashes and doesn't work on reboot. I have to wait until the next day.

sugar@hostname:~$ uname -v
#1 SMP Debian 3.16.7-ckt20-1+deb8u3 (2016-01-17)

sugar@hostname:~$ lspci -vnn | grep Network
04:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. 
RTL8821AE 802.11ac PCIe Wireless Network Adapter [10ec:8821]

sugar@hostname:~$ sudo iwconfig
eth0      no wireless extensions.

wlan0     IEEE 802.11abgn  ESSID:"Bravotelecom_9947"  
  Mode:Managed  Frequency:2.462 GHz  Access Point:     E8:CC:18:F7:81:50   
  Bit Rate=6.5 Mb/s   Tx-Power=20 dBm   
  Retry short limit:7   RTS thr=2347 B   Fragment thr:off
  Encryption key:off
  Power Management:off
  Link Quality=70/70  Signal level=-24 dBm  
  Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
  Tx excessive retries:0  Invalid misc:1   Missed beacon:0

lo        no wireless extensions.

I've tried to enable power management and then turn it off (even though it shows it is already turned off):

sugar@hostname:~$ sudo modprobe rtl8821ae swlps=1
sugar@hostname:~$ sudo iwconfig wlan0 power off
Error for wireless request "Set Power Management" (8B2C) :
SET failed on device wlan0 ; Operation not supported.

But I keep getting this error... anyway I don't think this is the problem.

I've also tried:

rfkill unblock -all

But nothing was soft or hard blocked to start with so no differences. My router is configured for IPv4 (not IPv6), and supports channels in 2 GHz and 5 GHz band. I have noticed that my Network Adapter switches between these two frequencies... sometimes I'm connected with low band and other times high band.

I will post the journalctl entries next time it crashes because I don't have them right now.

  • I share you pain. I have tried for days in a row to use two different realtek based devices. They are all crap. They crash your devices. They can have bugs at hardware, driver and firmware level. Please do read my answer here unix.stackexchange.com/questions/252210/… – Rui F Ribeiro Feb 11 '16 at 19:49

Add a "non-free" component to /etc/apt/sources.list :

# Debian 8 "Jessie"
deb http://httpredir.debian.org/debian/ jessie main contrib non-free

Update the list of available packages and install the firmware-realtek package:

sudo apt-get update && sudo apt-get install firmware-realtek

load module

sudo modprobe -rv rtl8821ae
sudo modprobe -v rtl8821ae
  • so the problem is network-manager? – Giovanni Toraldo Mar 4 '17 at 9:39
  • 1
    I think the problem is only the drivers/firmware. Installing firmware-realtek and loading the new module (modprobe rtl8821ae) should be enough to make it work with your network daemon of choice(NetworkManager, wicd, connman...) – user34720 Jun 15 '18 at 17:56
  • @nwildner exactly installing the non-free package should solve the problem, I will update this answer. – GAD3R Jun 15 '18 at 18:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.