1

I am not sure whether this constitutes a bug - so, I dare to try it here... When attempting to install (with dnf) versions of the package python-dns, I get the following

error: unpacking of archive failed on file /usr/lib/python2.7/site-packages/dnspython-1.12.0-py2.7.egg-info: cpio: rename

I run 4.3.4-300.fc23.x86_64 and have tried installing python-dns-1.12.0-2.fc23.noarch as well as python-dns-1.12.0GIT465785f-1.fc23.noarch.

The question is open, I am afraid: ideally I would learn how to solve the error; but I would also settle for advise where else I should post the question.

added information as reaction to comments

I used the command "sudo dnf install python-dns" to install the package. python-dns-1.12.0GIT465785f-1.fc23.noarch came from the default fedora repository "Fedora 23 - x86_64". python-dns-1.12.0-2.fc23.noarch came from http://koji.fedoraproject.org/koji/buildinfo?buildID=659336

1
  • 1
    where did you get these packages? What is the command you type before getting that error?
    – Jakuje
    Commented Feb 11, 2016 at 15:45

2 Answers 2

0

I usually get this when I've used pip to install/upgrade dnspython. This can happen inadvertently when using pip to install some other python package that has dnspython as a dependency. Try manually removing anything in /usr/lib/python2.7/site-packages/ related to dnspython and then try installing with dnf again.

1
0

This usually means the file was corrupted in transit in some way. Normally, I'd suggest

sudo dnf clean packages

and then

sudo dnf install python-dns

again. It sounds like you've already tried this, including going direct to koji (Fedora's package build system) for a newer version. So, next, I'd run rpm -K python-dns-1.12.0-2.fc23.noarch.rpm (or whatever you have for the actual RPM file). This should return that the checksums and signatures are okay. Then:

  1. If they're not okay, something is going wrong with your internet connection or you have a hardware problem causing corruption.
  2. If they are okay, I'd suggest filing a bug. For what it's worth, though, I can't replicate this on my system.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .