0

I'm trying to configure my RPi with Raspbian Jessie to use autofs to mount at boot a NFS share from my QNAP NAS.

The manual mount with

mount -v -t nfs server://share /mnt/share

works and also the autofs service works if I manually start it with

sudo service autofs start

after starting also rpcbind and nfs-common services first.

Now I want that all the 3 services involved (rpcbind, nfs-common and autofs) start automatically at boot.

Since Raspbian Jessie uses systemd, what should I do to add to the boot the rpcbind and nfs-common services, that should start before autofs?

Should I use init.d and so

sudo update-rc.d rpcbind enable

sudo update-rc.d nfs-common enable

or do I have to create a systemd unit file?

0

I'm not sure about Debian, but Ubuntu has a bug with that right now.

The current workaround is to add "x-systemd.automount" in the options section of the fstab line.

See bug 1515446.

  • I don't want to use fstab and so I have no fstab line. I need to understand how to correctly start at boot rpcrpcbind and nfs-common, before autofs. – Cheshire Cat Feb 11 '16 at 12:47
0

I finally found this solution. I used

sudo update-rc.d rpcbind enable

and

sudo update-rc.d nfs-common enable

to enable rpcbind and nfs-commond to start at boot, but only nfs-common starts correctly while rpcbind not.

So I found a workaround for rpcbind by adding

service rpcbind start

inside the /etc/rc.local script. I know it's not the proper way... but it works.

If anyone had any better suggestions, it is welcome!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.