I transferred my email setup to a new laptop, and fetchmail stopped fetching my mail. From what I can tell in the fetchmail log, it authorizes fine, sees that new emails are there, tries to fetch them, and fails due to a persistent "Temporary lookup failure" - here's the relevant log bit:

fetchmail: 2134 messages (2130 seen) for recent:patena at pop.gmail.com (397667985 octets).
fetchmail: POP3> LIST 2123
fetchmail: POP3< +OK 2123 679
fetchmail: POP3> RETR 2123
fetchmail: POP3< +OK message follows
fetchmail: reading message recent:patena@gmail-pop.l.google.com:2123 of 2138 (679 octets)Trying to connect to        connected.
fetchmail: SMTP< 220 bleen.gateway.2wire.net ESMTP Postfix (Ubuntu)
fetchmail: SMTP> EHLO bleen
fetchmail: SMTP< 250-bleen.gateway.2wire.net
fetchmail: SMTP< 250-PIPELINING
fetchmail: SMTP< 250-SIZE 307200000
fetchmail: SMTP< 250-VRFY
fetchmail: SMTP< 250-ETRN
fetchmail: SMTP< 250-STARTTLS
fetchmail: SMTP< 250-8BITMIME
fetchmail: SMTP< 250 DSN
fetchmail: SMTP> MAIL FROM:<patena@gmail.com> SIZE=679
fetchmail: SMTP< 250 2.1.0 Ok
fetchmail: SMTP> RCPT TO:<weronika@localhost>
fetchmail: SMTP< 451 4.3.0 <weronika@localhost>: Temporary lookup failure
fetchmail: SMTP error: 451 4.3.0 <weronika@localhost>: Temporary lookup failure
fetchmail: SMTP> RSET
fetchmail: SMTP< 250 2.0.0 Ok
fetchmail:  not flushed
fetchmail: POP3> LIST 2124

(And so on from "LIST" to "not flushed" for each unseen message.)

It's been going on for most of a day, so this temporary lookup failure doesn't seem very temporary.


The fetchmail: SMTP ... logs indicate that fetchmail is talking to a Mail Transport Agent (MTA), here Postfix, and Postfix has rejected the message from fetchmail on account of not being able to resolve the (unqualified!) hostname of localhost. Thus, the solution is to correct the DNS (and possibly hostname) for the system. This may also make sending mail from the system easier, as many mail servers will reject mail from hosts with unqualified names as an anti-spam measure.

An alternative would be to configure fetchmail via the mda setting to instead deliver directly to a program such as maildrop, thus cutting the local MTA out of the delivery loop.

  • You're right, thanks! I didn't understand the log well enough to realize the problem wasn't with fetchmail itself. Just uninstalling postfix (including config files) and re-installing it to go through the configuration process from scratch fixed my problem. – weronika Feb 10 '16 at 19:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.