0

I have installed Linux Mint 17.3 Mate on VirtualBox and have added a proxy, When using firefox I'm able to load webpages but when I try to run update of the system or to ping it fails , The update throws the following error:

GPG error: http://extra.linuxmint.com rosa InRelease: Clearsigned file isn't valid, got 'NODATA' (does the network require authentication?) enter image description here

2

For Synaptic Package Manager you need to configure proxy.

Open Synaptic -> Preferences -> Network, and configure your proxy there.

For terminal

Use terminal to open /etc/environment using a text edit app as superuser - e.g. in terminal type sudo gedit /etc/environment (enter password when asked)

Add the following lines to the text document that appears, replacing myproxy.server.com with your proxy address

http_proxy=http://myproxy.server.com:8080/
https_proxy=http://myproxy.server.com:8080/
ftp_proxy=http://myproxy.server.com:8080/
no_proxy="localhost,127.0.0.1,localaddress,.localdomain.com"
HTTP_PROXY=http://myproxy.server.com:8080/
HTTPS_PROXY=http://myproxy.server.com:8080/
FTP_PROXY=http://myproxy.server.com:8080/
NO_PROXY="localhost,127.0.0.1,localaddress,.localdomain.com"

Save the file, then navigate to /etc/apt/apt.conf.d/ and create a new file there named 95proxies and include the following code (remembering to add your own proxy address in place of myproxy.server.com)

Acquire::http::proxy "http://myproxy.server.com:8080/";
Acquire::ftp::proxy "ftp://myproxy.server.com:8080/";
Acquire::https::proxy "https://myproxy.server.com:8080/";

Reboot and once you have logged in you will find that your proxy settings are in place for Network Settings, apt-get and Update manager.

| improve this answer | |
  • Is there any way to use automatic proxy configuration ? – Pini Cheyni Feb 11 '16 at 9:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.