3

Using Linux Mint with Cinnamon.

I deleted some files using ShiftDel, so that they wouldn't go to the trash, but hoping they would be deleted immediately. However, the files are still there, they have only been renamed with a ~ at the end, making them invisible, but are not gone.

enter image description here

If I were to delete the tilde from the name the files would be restored. I see the functionality as some kind of safety net thug redundant with the trash can. If I was looking for a two step "safe" operation I would just send the files to the trash and then empty the trash.

Only by deleting the renamed files with ShiftDel again I can finally get rid of them.

So what is the One-Step operation to permanently delete files then?

  • 2
    as far as i know those are backup files so your files are not "renamed" but backups were "created". PS. I do not know what process/program is backing up your files – Dean Feb 10 '16 at 7:28
  • @Dean those "backups" only appear when I delete with Shift+Del... – cegaton Feb 10 '16 at 7:34
  • Seems logical, because if you delete them without shift they would just be moved to trash and can be restored from there, with Shift+Del they are deleted and cannot be restored from trash so you're machine is giving you backup files if you want them restored. But this is my opinion only. Maybe someone can confirm it for us :) let's wait – Dean Feb 10 '16 at 7:44
  • 1
    Maybe there are some custom keybindings which are making the backups on shift-delete ? Check the configuration with "gsettings get org.cinnamon.desktop.keybindings" OR "gsettings get org.cinnamon.desktop.keybindings custom-list" OR "gsettings get org.cinnamon.desktop.keybindings custom-keybindings". If there is a custom keybinding for shift-delete, remove it , reload & check. – Prem Feb 12 '16 at 10:24
  • 1
    @Prem thanks for ponting in the right direction – cegaton Feb 13 '16 at 0:04
3

The setting that controls immediate deletion is available in dconf-editor.

org nemo preferences enable-delete.

enter image description here

Even though the default setting is enabled it didn't work correctly. I disabled it and re-enabled it again, and now ShiftDel works as expected: Files-be-gone-for-good...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.