1

I'm running KDE Plasma 5.4.3 on Debian stretch/sid. I have kwin_wayland 5.4.3 and sddm 0.13.0.
I only installed the base system and then ran apt-get install kde-plasma-desktop/testing sddm/testing (and all updates & upgrades afterwards and before).

It kinda works - there is a nice login screen and it can create windows; However none of them have any window decorations (e.g. the minimize/maximize/close buttons are missing) which I miss dearly.

My .xsession_errors file is here

There is an older question with my problem, but it is for KDM which isn't used in the new version.

3

I had same problem on my kali linux(kali-rolling version). I solved this problem, just installed 'kwin-x11'

sudo apt-get install kwin-x11 kwin-decoration-oxygen 

I think this might solve your problem too.

  • Well, it doesn't exactly solve the issue but hey I got what I wanted – user45891 Feb 10 '16 at 15:23
0

You need to install plasma-applet-active-window-control

Dependency:

sudo apt-get install cmake extra-cmake-modules plasma-workspace-dev plasma-framework-dev build-essential qtcreator

then

git clone git://anongit.kde.org/plasma-active-window-control

Install

cd plasma-applet-active-window-control
cmake .
make
sudo make install

then Reboot.

SETTING KWIN PROPERLY

if you want borderless windows you can set it in this way :

kate ~/.config/kwinrc

under [Window] you should put

BorderlessMaximizedWindows=true

To launch Window Manager settings type the following command:

kcmshell4 kwincompositing kwindecoration kwinoptions kwinrules kwinscreenedges kwintabbox 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.