3

How can I prevent other applications from stealing focus from the active window? I have found solutions for other window managers, but nothing for "Metacity (Marco)" (the window manager of the MATE desktop manager).

I don't want to have to specify every time which window must be "always on top", unless it can be done automatically every time I switch to a new window.

I have determined the window manager by running wmctrl -m.

EDIT:

I have tried switching the focus-new-windows flag from smart to strict for both Gnome and Mate(Marco):

$ gsettings set org.gnome.desktop.wm.preferences focus-new-windows strict
$ gsettings set org.mate.Marco.general focus-new-windows strict

But it didn't work.

8
  • 1
    AFAIK, MATE is a desktop environment. It isn't a window manager. Depending on which version of MATE you're using, you may have a choice of window managers to choose from.
    – DK Bose
    Feb 9, 2016 at 15:14
  • @DKBose: Thanks for the observation. The window manager is Metacity. I have updated my question.
    – Eleno
    Feb 9, 2016 at 16:20
  • Please see if this (old) blog post is of help: bertrandbenoit.blogspot.in/2011/09/…
    – DK Bose
    Feb 9, 2016 at 16:26
  • Thanks, but gconftool-2 says that the value /apps/metacity/general/no_focus_windows does not exists (and indeed the whole /apps/metacity tree is missing.
    – Eleno
    Feb 9, 2016 at 17:31
  • well... focus-new-window wont work since the description says: This option provides additional control over how newly created windows get focus. It has two possible values; "smart" applies the user's normal focus mode, and "strict" results in windows started from a terminal not being given focus. Mar 6, 2016 at 9:41

1 Answer 1

0

In general, you need to install an extension to eliminate the behavior in gnome-shell, where gnome displays a "Window is ready" notification rather than giving the new window focus. The extension "Noannoyance" appears to be the best maintained, but alternatively "Steal My Focus" or "Focus my window" probably still work fine.

link: https://extensions.gnome.org/extension/2182/noannoyance/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .