1

I have an AMD Athlon 5350 (desktop, not a notebook) and recently upgraded from openSUSE 13.2 to Tumbleweed (openSUSE's rolling release). After that I gave suspend to RAM another try after it had just crashed my system when I last tried with 13.2.

To my surprise it mostly works now. But my mouse (very simple Logitech model) does not wake up. Disconnecting and reconnecting makes it blaze for a very short moment, then it turns dark again. The same result in the neighbour USB port. The funny part: In a third port it did work again. Until the next suspend after which it did not work on four ports (I assume that is two busses). This is not a mouse problem but a port problem: My ventilator which just takes electricity from the port still works but the system does not recognize real USB devices any more.

I currently avoid the problem by starting suspend with the keyboard and disconnectiong the mouse immediately before... But there has to be a better solution. I don't have a notebook thus I am not familiar with this power management stuff and its problems. But I assume that the kernel stores information about the device state somewhere in /sys/ which may be changed manually.

I cannot say for sure whether lsusb still shows all the USB busses (hubs).

dmesg output

Messages which may be related to the problem:

When the system suspends, these lines appear:

PM: suspend of devices complete after 795.355 msecs
PM: late suspend of devices complete after 1.376 msecs
pcieport 0000:00:02.4: System wakeup enabled by ACPI
r8169 0000:02:00.0: System wakeup enabled by ACPI
ehci-pci 0000:00:13.2: System wakeup enabled by ACPI
ehci-pci 0000:00:12.2: System wakeup enabled by ACPI
xhci_hcd 0000:00:10.0: System wakeup enabled by ACPI
PM: noirq suspend of devices complete after 14.713 msecs
ACPI: Preparing to enter system sleep state S3

When it wakes up, these line appear:

ACPI: Waking up from system sleep state S3
pcieport 0000:00:02.4: System wakeup disabled by ACPI
ehci-pci 0000:00:12.2: System wakeup disabled by ACPI
xhci_hcd 0000:00:10.0: System wakeup disabled by ACPI
ehci-pci 0000:00:13.2: System wakeup disabled by ACPI
PM: noirq resume of devices complete after 13.259 msecs
PM: early resume of devices complete after 0.378 msecs
  • Any relevant message in dmesg ? – SHW Feb 9 '16 at 6:49
  • @SHW Connecting devices to the affected ports does not create messages in dmesg. – Hauke Laging Feb 9 '16 at 6:51
  • While waking up, kernel prints few messages. Did you find any clue in those messages ? – SHW Feb 9 '16 at 6:52
  • 1
    @SHW I found some lines and added them to the question. – Hauke Laging Feb 9 '16 at 7:02
  • Checkout this askubuntu answer. – Pablo A Oct 4 '17 at 14:10
1

Use the following parameter as kernel option (in grub2):

usbcore.autosuspend=-1

After using this, you will find:

cat /sys/module/usbcore/parameters/autosuspend
-1

The default value is 2. The kernel parameter changes this value.

Setting the kernel parameter helped me. Now my mice works again, when resuming from suspend.

Suggestion: When USB devices don't work after suspend, you can also reload the driver using the following commands as root:

modprobe -r uhci_hcd
modprobe uhci_hcd

and / or

modprobe -r ehci_hcd
modprobe ehci_hcd

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.