1

I'm in NetBSD installation process, when configuring network, I'm stuck in this command and there is no way out of it:

Status: Command failed
Command: /sbin/ifconfig fwip0 media
Hi enter to continue

When I hit enter, I'm asked for a net media type:

Net media type []:

Anything that I enter, returns the following error message, even when I enter "autoselect" the error message appears again and again without getting out of the process:

---------------------------------------------
ifconfig: SIOCGIFMEDIA: Inappropriate ioctl for device

The screenshots are shown below:

enter image description here

When hit Ctrl+z and then type ifconfig, I receive the following data for fwip0 device:

enter image description here

Actually, before I run into above mentioned issue, I configured another device (bge0) which worked fine.

Therefore, bge0 worked fine, but fwip0 is stuck and I cannot get out of installation process. Can anybody help. I cannot use that computer and I'm posting this question with somebody else's machine!

2

I run into a similar problem in the past which I solved by setting the media type to none.

  • I tried many words, but unfortunately didn't try "none" I wish I had tried – user3405291 Feb 9 '16 at 14:11
  • Since firewire doesn't really have a "media" interface, none is probably the only valid media type to use with fwip interfaces (though manual might also work). See the fine manual ifmedia(4) for a bit more info. – Greg A. Woods Feb 10 '16 at 20:55
1

I'm not sure why the firewire (fwip) interface is causing issues, but two things you might try, either of which should help:

  1. Go into the BIOS setup and disable the firewire interface
  2. Hit space to interrupt the NetBSD boot, then use boot -c to enter userconf at which point you should be able to disable fwip0 and then quit to continue the boot
  • Actually, I pressed "Ctrl+z" and then typed "ps" there was a process named "sysinst" so I typed "kill [process ID of sysinst]" and got out of installation process. I'm formatting the disk and I'm going to start installation from scratch again. This time I will not try to configure the firewire (fwip0). – user3405291 Feb 9 '16 at 9:38
  • I started installation process again, and I didn't configure firewire (fwip0). Everything is fine now and NetBSD is being installed without problem. – user3405291 Feb 9 '16 at 10:15
  • Indeed it is best to avoid trying to configure device drivers that are not needed. – Greg A. Woods Feb 10 '16 at 20:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.