1

I've installed a fresh Wordpress site on my Amazon Linux AMI following the setup instructions listed on the EC2 Tutorials section i.e. "Hosting a WordPress Blog with Amazon Linux". I'm also using the "WP S3 Offload" plugin so that I can use S3 to store my media files, rather then housing them on the EC2 instance. Ok, all that said the "WP S3 Offload" plugin is showing an error/warning message that says, "Image Manipulation Library Missing — Looks like you don't have an image manipulation library installed on this server and configured with PHP. You may run into trouble if you try to edit images. Please setup GD or ImageMagick."

I know I could search yum packages by typing sudo yum search ImageMagick in my EC2 instances terminal, which is what I did... and a list of available packages came up. Since I have PHP v5.6 installed, I decided to use the php56-pecl-imagick package via sudo yum install -y php56-pecl-imagick. I assumed that would take care of the problem but the "WP S3 Offload" plugin is still showing that same warning about the Image Manipulation Library Missing.

  1. Did I install/configure the ImageMagick package correctly?
  2. Is there another or more optimal way to install the ImageMagick package?
  3. How can I test if the package is installed or not?
  4. Am I missing any other packages?
  • Did it also install ImageMagick itself, i.e. are the binaries present? Check what is returned by convert --version and best also provide the output of rpm -qa|sort|grep -i magick – doktor5000 Feb 10 '16 at 11:54
  • So is the full command I need to run convert --version rpm -qa|sort|grep -i magick or do I run them as separate commands i.e. run convert --version and then run rpm -qa|sort|grep -i magick? – Corey Feb 10 '16 at 16:09
  • Those are separate commands. – doktor5000 Feb 10 '16 at 16:35
  • 1
    Hey @doktor5000 that worked and it appears as if I did install it correctly when I typed convert --version I received a response of Version: ImageMagick 6.7.8-9 2015-10-08 Q16 http://www.imagemagick.org Copyright: Copyright (C) 1999-2012 ImageMagick Studio LLC Features: OpenMP and when I ran rpm -qa|sort|grep -i magick I received a response of ImageMagick-6.7.8.9-10.18.amzn1.x86_64 php56-pecl-imagick-3.1.2-2.14.amzn1.x86_64. So it appears as if I installed everything correctly. If you can anwer the question with your previous response, I'll mark it as correct. Thanks. – Corey Feb 12 '16 at 15:22
  • +Corey Added as answer. – doktor5000 Feb 12 '16 at 23:43
0

Adding this as an answer as it seems to have helped:

You should ensure that ImageMagick itself is installed, i.e. make sure that the actual binaries are present. Check what is returned by convert --version and also provide the output of
rpm -qa|sort|grep -i magick which should confirm that ImageMagick and php56-pecl-imagick are installed.

I've tested with a recent CentOS installation, and there php-pecl-imagick already requires ImageMagick, but it seemed to be missing on your installation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.