2

I cannot go beyond 800MHz on my Dell XPS 13 Ivybridge CPU.

$ cpupower frequency-info
analyzing CPU 0:
  driver: intel_pstate
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 0.97 ms.
  hardware limits: 800 MHz - 2.60 GHz
  available cpufreq governors: performance, powersave
  current policy: frequency should be within 1000 MHz and 2.60 GHz.
                  The governor "performance" may decide which speed to use
                  within this range.
  current CPU frequency is 800 MHz.
  boost state support:
    Supported: yes
    Active: yes
    25500 MHz max turbo 4 active cores
    25500 MHz max turbo 3 active cores
    25500 MHz max turbo 2 active cores
    25500 MHz max turbo 1 active cores

Even if issue sudo cpupower frequency-set -g performance I still get 800MHz. Then I tried

$ sudo cpupower frequency-set -f 2.60GHz
Setting cpu: 0
Error setting new values. Common errors:
- Do you have proper administration rights? (super-user?)
- Is the governor you requested available and modprobed?
- Trying to set an invalid policy?
- Trying to set a specific frequency, but userspace governor is not available,
   for example because of hardware which cannot be set to a specific frequency
   or because the userspace governor isn't loaded?

...no luck. My laptop is slow especially when running on battery. I saw that there was an open bug here which seems to be similar to my experience but it was closed for not enough info. Can someone help me please?

EDIT:

I booted with the intel_pstate=disable option and now I can set frequencies and governors. However my laptop is still slow and unresponsive even in performance mode, so there's something else giving problems.

  • could be that your charger has failed and is no longer recognized as a Dell(tm) charger. When that happens my latitude d630 locks itself to 800mhz, too, and refuses to charge. – Wyatt8740 Feb 8 '16 at 11:53
1

you need to load the userspace module

modprobe cpufreq_userspace

and set the governor

cpupower frequency-set --governor userspace

The files in /sys/devices/system/cpu/cpu0/cpufreq/ provide information and a means of controlling the frequency scaling subsystem. Seed values are given in Khz. You need to be root to access the /sys filesystem.

Example:

Your max speed is at /sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_max_freq.

cat /sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_max_freq
700000

Your min speed is at /sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_min_freq.

cat /sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_min_freq
500000

you can write to /sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeed to change the current speed.

echo 700000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeed

cat /proc/cpuinfo

cpu MHz  : 697.252

echo 900000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeed
cat /proc/cpuinfo
cpu MHz  : 976.152

To get more informations how to change frequency

http://www.thinkwiki.org/wiki/How_to_make_use_of_Dynamic_Frequency_Scaling

To show frequency and more informations try to install i7z

sudo apt-get update
sudo apt-get install i7z

to run i7z type: sudo i7z

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.