4

I've installed Debian stable (Jessie) on a Acer Notebool (Aspire ES 15).

If I try to start some programs (qtcreator, processing) I see:

LLVM ERROR: Cannot select: intrinsic %llvm.x86.sse41.pblendvb

I think the reason is a not working 3D acceleration.(But I'm not sure) I already installed the video-intel package with:

apt-get -t jessie-backports install xserver-xorg-video-intel

but this didn't change anything (even after reboot).

$ sudo lspci -vnn | grep VGA -A 10
00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:22b1] (rev 21) (prog-if 00 [VGA controller])
        Subsystem: Acer Incorporated [ALI] Device [1025:1012]
        Flags: bus master, fast devsel, latency 0, IRQ 7
        Memory at 90000000 (64-bit, non-prefetchable) [size=16M]
        Memory at 80000000 (64-bit, prefetchable) [size=256M]
        I/O ports at 2000 [size=64]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: [d0] Power Management version 2
        Capabilities: [90] MSI: Enable- Count=1/1 Maskable- 64bit-
        Capabilities: [b0] Vendor Specific Information: Len=07 <?>

$ glxinfo | grep -i opengl -A 3
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.5, 128 bits)
OpenGL version string: 3.0 Mesa 10.3.2
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
    GL_AMD_conservative_depth, GL_AMD_draw_buffers_blend, 
    GL_AMD_seamless_cubemap_per_texture, GL_AMD_shader_trinary_minmax, 
    GL_ANGLE_texture_compression_dxt3,
    GL_ANGLE_texture_compression_dxt5, 

$ uname -a
Linux Bernd 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt20-1+deb8u3 (2016-01-17) x86_64 GNU/Linux

$ xdriinfo 
Screen 0: not direct rendering capable.
4

I solved it by updating my kernel from 3.16 to 4.3. For Debian Jessie, the new kernel can be installed from backports:

apt-get -t jessie-backports install linux-image-4.6.0-0.bpo.1-686-pae

Actual image name will depend on what kind of hardware you have and what kernel flavour you prefer.

  • wellcome to U&L SE, maybe you can give more details ? – Archemar Feb 28 '16 at 14:06
  • Yes, please include the command(s) you ran to upgrade. – terdon Feb 28 '16 at 14:07
  • I had a similar issue and can confirm that upgrading the kernel does solve it. – Dmitry Grigoryev Jul 15 '16 at 21:09
  • Note that, depending on your needs, you may also want to install other backports packages. For example, I needed to install xserver-xorg-video-intel and restart Xorg to bid adieu to the lvvm complaint... – thomp45793 May 29 '17 at 16:52
0

I am no Linux connoisseur, but to me installing libgl1-mesa-swx11 did at least part of the trick : 3d functionalities now seem to work.

(note : libgl1-mesa-glx was suppressed at the installation of libgl1-mesa-swx11)

  • 2
    The downvotes are probably because (and I just tried this so I can confirm) swx11 means it's implementing mesa (ie openGL's api) in software (ie not the graphics card), so the framerate is too low for any practical use. – Eamonn M.R. May 16 '16 at 19:33
0

I've had the same issue today, fresh Debian Jessie with the Intel graphical chipset that's in the Celeron N3050 ; I found this question and answer. Unfortunately upgrading the Kernel did not help. However, upgrading all of the following packages from jessie-backports did solve the issue :

libegl1-mesa
libegl1-mesa-drivers
libgl1-mesa-dri
libgl1-mesa-glx
libglapi-mesa
libgles1-mesa
libgles2-mesa
libglu1-mesa
libopenvg1-mesa
libtxc-dxtn-s2tc0
libwayland-egl1-mesa
mesa-utils
mesa-utils-extra
libva-drm1

protected by Community Jul 1 '17 at 21:34

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.