2

I've a Dell XPS 13 L321x running Debian Jessie that cannot resume after being suspended. Hibernate works fine if you trigger it with pm-hibernate.

I've tried rmmod on the mei and mei_me drivers suggested in https://bugzilla.kernel.org/show_bug.cgi?id=86241 but no effect. I've similarly tried rmmod on the various wifi drivers linked to iwlwifi since https://askubuntu.com/questions/638835/xps-13-9343-failure-to-resume-from-suspend explained similar issues in much more recent XPS 13s, but again no effect.

I should probably actually blacklist these modules, or perhaps remove the wifi card itself. I could try using a 4.3 kernel too.

How can I actually diagnose the problem with resume though? Are there any ways to log the resume operation the way that suspend is logged?

I've found better information on suspend at https://wiki.ubuntu.com/UnderstandingSuspend and technique for debugging resume at https://wiki.ubuntu.com/DebuggingKernelSuspend although it does not work on my current kernel.

After playing around with single user mode suspend I feel confident the system simply does not detect the lid open event or key press events when suspended. And hibernate works because initially it's powering-on like normal. I suspect Linux is simply being too aggressive with the hardware that it deactivates when doing suspend. Any thoughts?

0

Are there any ways to log the resume operation the way that suspend is logged?

Yes /var/log/pm-suspend.log :D

  • It's kinda useless since it'll never be written to if suspend does not work. – Jeff Burdges Feb 7 '16 at 13:27
  • Well, I understand, that suspend is working and resume is not working. It's suposed, that you can read all resume operations..... Did you try it? – ncomputers Feb 7 '16 at 19:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.