0

I have installed fedora 23 and have dual boot with Windows 10 on Dell Inspiron 1545. The system doesn't recognize the wireless card with is Broadcom BCM4312. I downloaded several rpms and tried to install them but failed.

I managed to install rfkill but

rfkill list wifi 

gives nothing

rfkill list all

gives nothing as well.

What I have is

rpmfusion-free-release-23.noarch.rpm

pmfusion-nonfree-release-23.noarch.rpm

kmod-wl-4.2.3-300.fc23.x86_64-6.30.223.271-4.fc23.x86_64.rpm

kmod-wl-6.30.223.271-4.fc23.x86_64.rpm

broadcom-wl-6.30.223.271-1.fc23.noarch.rpm

When I tried to install them via 'sudo dnf ' it failed because it tried to download updates which is not possible since there is no connection with the Internet.

I managed to install

rpmfusion-free-release-23.noarch.rpm

pmfusion-nonfree-release-23.noarch.rpm

by running 'sudo rpm -ivh ' but when I run

sudo rpm -ivh kmod-wl-6.30.223.271-4.fc23.x86_64.rpm

I get

warning: kmod-wl-6.30.223.271-4.fc23.x86_64.rpm: Header V4 RSA/SHA1 Signature, key ID 5ca6c469: NOKEY
error: Failed dependencies:
    kmod-wl-4.2.3-300.fc23.x86_64 >= 6.30.223.271-4.fc23 is needed by kmod-wl-6.30.223.271-4.fc23.x86_64

I tried to run

sudo rpm -ivh kmod-wl-4.2.3-300.fc23.x86_64-6.30.223.271-4.fc23.x86_64.rpm

but I got

warning: kmod-wl-4.2.3-300.fc23.x86_64-6.30.223.271-4.fc23.x86_64.rpm: Header V4 RSA/SHA1 Signature, key ID 5ca6c469: NOKEY
error: Failed dependencies:
    wl-kmod-common >= 6.30.223.271 is needed by kmod-wl-4.2.3-300.fc23.x86_64-6.30.223.271-4.fc23.x86_64

I wanted to connect with the internet via android smartphone but I didn't find an option to establish a connection via usb.

I there a way to install the packeges kmod and broadcom-wl? Can anybody suggest a solution? Thanks in advance...

  • why the down vote ? – mt_had Feb 6 '16 at 14:21
  • I also asked at fedoraforum.org but did not manage to get a solution so I posted here. Anyway, it is resolved already. – mt_had Feb 6 '16 at 15:27
  • @mt_had If you have an answer, please post it. – Faheem Mitha Feb 6 '16 at 15:33
  • This question is perfectly on topic here and it's ridiculous to downvote or send people off to askfedora, which is a fine project, but there's no reason at all that one would need to do that. (Disclaimer: I work on Fedora.) – mattdm Feb 7 '16 at 13:22
2

I was advised to put all three rpm packages in one directory and run one command and so I did and it worked.

So I put

kmod-wl-4.2.3-300.fc23.x86_64-6.30.223.271-4.fc23.x86_64.rpm

kmod-wl-6.30.223.271-4.fc23.x86_64.rpm

broadcom-wl-6.30.223.271-1.fc23.noarch.rpm

in a new directory and ran

sudo rpm -ivh *.rpm

It worked and after rebooting the system I was able to find available wireless connections and connect.

0

Apparently there are issues with Broadcom licensing their drivers or allowing others to create drivers. My solution was to buy a different wireless networking module to replace the Broadcom one that came standard in my Yoga 3 Pro.

I purchased this module.

Took 10 minutes tops to install and works flawlessly. No drivers to install, nothing to configure. The answer is to ditch Broadcom alltogether and get an aftermarket internal card that's compatible.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.