I have a Ubuntu 11.10 system both at home and at work. I would like to connect to my work computer via SSH but it is inaccessible (even ping does not work).

Teamviewer however does work, and I thought perhaps the ssh port 22 was blocked, so tried accepting SSH connections via ports 80 (http), 443 (https), and 5938 (tcp/udp). Still not working.

Any ideas how I can connect to the computer via SSH? Also, any ideas why TeamViewer works over port 80 whereas SSH does not?

  • Teamviewer, for what I know, works with an intermediate server (provided by Teamviewer company), so that none of the two end of the communication need to listen and accept connection, working effectively as client to the intermediate server. This setup avoid problems like yours, but is clearly not applicable to open software where no intermediate server could be provided. – enzotib Dec 4 '11 at 8:10
  • Do a search for "reverse ssh tunnel". But I'd first make sure you understand why you can't connect via ssh. The obvious answer is a firewall, but then someone should be able to tell you about this. Another possibility is to get to your computer via another in two hops. – Faheem Mitha Dec 4 '11 at 12:39
  • 1
    How are you trying to access it,does your work machine have a public ip address or is it internal behind a router if so do you have the relevant ports ie 22 forwarded to your work machine? – 0x7c0 Dec 4 '11 at 18:03

Is your home computer public? Does it accept connections from your work computer? I would think of establishing a remote tunnel on the local computer at home and then try to link that with remote port of the remote host locally for a reverse flow too.


First, did you first check with your office IT group to make sure you are allowed to run an ssh server on your system? Some workplaces will forbid that type of remote access. Therefore, if your workplace will not allow SSH connectivity remotely, then you should disregard the second part of this answer, because running what the second part says could get you fired or loss of privileges.

Secondly, if you are allowed, you would need to install an ssh daemon, openssh_server. SSH and TeamViewer run on separate protocols, which is why SSH via port 80 wont work.

  • When on the work machine, ssh -p 80 localhost works ok. The problem is accessing it from a computer on a different network. – the combo Dec 4 '11 at 1:19
  • Then you need to talk to your company's IT people as my initial part says. Most likely they are restricting access from outside the network, and there would have to be a special modification on the firewall to allow such access. Your organization might not allow that, which is why you can't currently access SSH from outside the network. As well, your organization might just not allow it, period, based on their IT policies (some organizations do this) – Thomas Ward Dec 4 '11 at 1:23
  • Thanks yes the university has no policy against it and several colleagues use TV or ssh. This seems to be a problem with the way I have it set up? Is it even possible for a firewall to open a port (e.g. 80) yet filter by content on that port -- i.e. http and teamviewer works but ssh does not. – the combo Dec 4 '11 at 1:29
  • I'd start by trying via port 22. that's the standard SSH port. Its EXTRAORDINARILY RARE to find an SSH server running on port 80 (the HTTP port) – Thomas Ward Dec 4 '11 at 3:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.