1

I'm trying to install haproxy to my Debian Server. I have followed the instructions as below:

  • create a new file called backports.list in /etc/apt/sources.list.d

  • Add the follwing to the file: deb http://cdn.debian.net/debian wheezy­backports main

  • run: apt­-get update

  • run: apt-get install haproxy

The problem is that when I do the update it tells me that:

Err http://cdn.debian.net wheezy­backports/main amd64 Packages
404  Not Found [IP: 128.31.0.66 80]

W: Failed to fetch http://cdn.debian.net/debian/dists/wheezy­backports/main/binary-amd64/Packages  404  Not Found [IP: 128.31.0.66 80]

E: Some index files failed to download. They have been ignored, or old ones used instead.

Is there a way to get round this? (I'm new to Linux so I apologise if this has an easy/obvious answer). I've tried searching but can't seem to see anything obvious.

closed as off-topic by Stephen Kitt, Jakuje, cuonglm, slm Feb 5 '16 at 18:55

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Stephen Kitt, Jakuje, cuonglm, slm
If this question can be reworded to fit the rules in the help center, please edit the question.

2

You need to add the hyphen in wheezy-backports:

 deb http://cdn.debian.net/debian wheezy­-backports main

See the backports website for the complete instructions.

  • cheers, that fixed it. It just shows that blindly copying and pasting from websites doesn't always work. – IGGt Feb 5 '16 at 15:43

Not the answer you're looking for? Browse other questions tagged or ask your own question.