2

I have yum and rpm, and I really only know how to install packages using these commands. When I tried to yum install figlet on a new CentOS6 virtual machine it couldn't find it in the mirrors list. I tried to localinstall a figlet package but it wasn't signed and yum wouldn't install it.

OR

better yet how do you got about adding a package (or a mirror?) if the .rpm you're looking for isn't availabe in your VM build of CentOS?

In this case I want to add figlet and toilet!

UPDATE If I install a package manually, do I need to do it from a particular directory? or does Yum/RPM have a dir they always use automagically?

2
  • Find the RPM, download it manually, and use rpm -i (as I recall; it's been a long time since I've used redhat.)
    – Kevin
    Dec 3, 2011 at 21:44
  • I did download it locally and did yum localinstall but it complained that the package wasnt signed.
    – qodeninja
    Dec 3, 2011 at 22:13

1 Answer 1

4

Here you can download the figlet packge and install it with rpm -U or rpm -ivh package.rpm, or do yum localinstall --nogpgcheck packgename.

You don't need to run the yum command from a particular directory.

As a general recommendation, I encourge you to add the RpmForge repos to you centos installation, since it includes a lot of programs.

1
  • I've tried sudo yum localinstall --nogpgcheck figlet-2.2.2-1.el6.rf.x86_64.rpm Loaded plugins: langpacks, refresh-packagekit Cannot open: figlet-2.2.2-1.el6.rf.x86_64.rpm. Skipping. Nothing to do - Can someone please help ?
    – code-8
    Jan 21, 2016 at 14:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .