With my new built computer Ubuntu 10.4 lucid won't hibernate or suspend. It's a custom-built Core i7 on the Gigabyte X58A-UD3R motherboard. Hibernate is enabled in the bios.

Running sudo hibernate gives:

hibernate:Warning: Tuxonice binary signature file not found. Some modules failed to unload: nvidia hibernate: Aborting suspend due to errors in ModulesUnloadBlacklist (use --force to override).

After installing, linux-generic-tuxonice and linux-headers-generic-tuxonice, and rebuilding my nvidia dev drivers, it still does not work. But I think I'm closer. Now, when I run sudo hibernate I get:

hibernate: TuxOnIce reported the following errors:
 - TuxOnIce was aborted (see dmesg).
 - Some devices refused to suspend (see dmesg).

"gmesg | grep error" returns

 [  736.173906] PM: Device usb9 failed to freeze: error -2
 [  736.642208]                  : A device suspend/resume returned an error.

Any ideas how to find out what is on usb9 and why it's failing to freeze. The only thing that I have on usb is the keyboard and mouse.

  • 2
    can you provide more information please. How do you try to hibernate? And what happens when you do? – Stefan Oct 1 '10 at 21:35
  • I select hibernate from the menu, it gives a cursor, cursor disappears, then act just as if the screen was locked. Sorry much more to add by way of details. – Andrew Redd Oct 1 '10 at 21:53
  • 1
    Try running sudo /sbin/hibernate from your console. And copy-paste the results in your question ( if it doesn't work ). – Stefan Oct 2 '10 at 6:17
  • Are you running Ubuntu 64 bit? I'm experiencing a slew of problems on 64bit and nvidia graphics cards. – Gert Oct 6 '10 at 18:37
  • yes 64 bit Ubuntu 10.4 – Andrew Redd Oct 6 '10 at 20:00

According to this thread you need to have Tuxonice installed. While I'm not entirely sure about this, can you open synaptic and look for packages named "tuxonice"? Unfortunately, different posts say different things, so all that I can help is this guide.

Good luck :)

  • That helps. It appears that the NVIDIA modules are unloading but the it is still not staying in hibernation. I do get the warning "hibernate:Warning: Tuxonice binary signature file not found." – Andrew Redd Oct 15 '10 at 14:13
  • even after installing the tuxonice packages? then maybe you need to change the kernel – phunehehe Oct 15 '10 at 14:49
  • 1
    What a pain that was. I installed the linux-generic-tuxonice package. Which killed my nvidia drivers. So I had to install the headers and rebuild my NVIDIA drivers. An hour wasted and it still doesn't work. – Andrew Redd Oct 15 '10 at 15:19

It might help to find out what usb9 refers to. To do this, have a look at /sys/bus/usb/drivers/usb9/{product,idProduct,idVendor}, which should help you what particular USB device is refusing to suspend. If it's something you can unplug, try without that.


I know that this might not help anyone, but it hibernates now that I updated to 11.04 Natty. I'm still using the Nvidia drivers and all the peripherals are the same.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.