1

After extract eclipse-jee-mars-1-linux-gtk.tar.gz and running eclipse I am getting following error. I have installed Oracle JDK. What would be the error and solution ?

Java version

[root@hithertech eclipse-modeling-mars-1]# java -version
java version "1.7.0_25"
Java(TM) SE Runtime Environment (build 1.7.0_25-b15)
Java HotSpot(TM) 64-Bit Server VM (build 23.25-b01, mixed mode)

Error on running eclipse-jee-mars-1-linux

Eclipse:
GTK+ Version Check
Eclipse:
JVM terminated. Exit code=13
/usr/bin/java
-Dosgi.requiredJavaVersion=1.7
-XX:MaxPermSize=256m
-Xms256m
-Xmx1024m
-jar /usr/local/eclipse-modeling-mars-1//plugins/org.eclipse.equinox.launcher_1.3.100.v20150511-1540.jar
-os linux
-ws gtk
-arch x86
-showsplash /usr/local/eclipse-modeling-mars-1//plugins/org.eclipse.platform_4.5.1.v20150904-0015/splash.bmp
-launcher /usr/local/eclipse-modeling-mars-1/eclipse
-name Eclipse
--launcher.library /usr/local/eclipse-modeling-mars-1//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.1.300.v20150602-1417/eclipse_1612.so
-startup /usr/local/eclipse-modeling-mars-1//plugins/org.eclipse.equinox.launcher_1.3.100.v20150511-1540.jar
--launcher.appendVmargs
-exitdata 220011
-product org.eclipse.epp.package.modeling.product
-vm /usr/bin/java
-vmargs
-Dosgi.requiredJavaVersion=1.7
-XX:MaxPermSize=256m
-Xms256m
-Xmx1024m
-jar /usr/local/eclipse-modeling-mars-1//plugins/org.eclipse.equinox.launcher_1.3.100.v20150511-1540.jar 
1

Check that the JVM version (32/64 bit) you use matches the eclipse version (32/64 bit).

I find these lines conflicting.

Java HotSpot(TM) 64-Bit Server VM (build 23.25-b01, mixed mode)

arch x86

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.