1

[Edited: The issue was entirely due to own negligence. I was typed in an incorrect ip address. No issues logging in with the correct ip address.]

Problem:

Cannot ssh into a ubuntu 14.01 server (tried using PuTTY and RoyalTS) from a Windows 8.1 laptop.

  • The terminal window comes up with prompt for the username and then the password, which then fail
  • Error reported in PuTTy is authentication failed.
  • Similar error in RoyalTS 2016-02-04 17:26:49.587 ERROR Ssh(1)[19] SSH: Rebex.Net.SshException: A supplied password or user name is incorrect.
  • Can log into the same server using a IPMI connection using the same laptop and same username and password credentials (the same ones that fail in the ssh). The username and password were created when setting up the machine using this same IPMI connection.

How can I check and then ensure that the keyboard setup is the same when using the ssh (Putty / RoyalTS / etc.) and the IPMI connections? I read somewhere that this could be the issue.

Is there something else that I am I missing something here? Any workarounds?

closed as off-topic by Thomas Dickey, Jeff Schaller, Stephen Harris, dhag, Networker Jul 25 '16 at 6:29

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Thomas Dickey, Jeff Schaller, Stephen Harris, dhag, Networker
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    You're not logging in as root, are you? Can you log in with ssh on the console (not over the network) using those credentials? – captcha Feb 5 '16 at 3:33
  • I am using the same username and password that were created when setting up the system. I will try the suggestion of logging in using ssh over the console – cv1 Feb 5 '16 at 11:50
  • I tried using a different windows machine to ssh into the machine with the same result - access denied – cv1 Feb 5 '16 at 11:54
  • I was able to successfully ssh using the console using the credentials. But, again, ssh did not work on when used from Putty on windows. – cv1 Feb 5 '16 at 22:42
  • 1
    Thanks to your tip about ssh from the console, I found out I was trying to ssh using an incorrect ip address. I had no issues ssh into the server when I used the correct ip address. – cv1 Feb 12 '16 at 20:07
0

You can generate the ssh key and add generated SSH key in the file ~/.ssh/authorized_keys. Seems that root login is disabled in sshd_config file. You can check it also.

  • OP already confirmed that logging in on the console works, so root logins are not disabled in /etc/ssh/sshd_config. – captcha Feb 5 '16 at 22:50
0

Thanks to the tip from captcha about ssh from the console, I found out (from the console information) I was trying to ssh using an incorrect ip address. I had no issues ssh into the server with the correct ip address.

So, the issue was entirely due to own negligence.

Not the answer you're looking for? Browse other questions tagged or ask your own question.