0

I just added a D-Link DWA-582 PCI-e WiFi adapter using the Realtek RTL8812AE chipset. I confirmed the support for the chipset at https://wiki.debian.org/rtl819x#rtl8821ae . I have installed the Realtek firmware using apt-get install firmware-realtek and confirmed that it is in use using modprobe rtl8821aeWhen I connect to the wireless access point I can maintain a connection for ~6 seconds. I usually am connected just long enough to establish a dhcp lease and then the network disconnects again. I have not been very successful in finding much information on how to diagnose/resolve this issue despite several hours of reading forum posts and trying suggestions.

I have tried replacing Network Manager with wicd without any change or improvement.

I am not really sure what the best information is for diagnosing this issue, so I have posted something to get started, and I hope all you guru's will want more and/or have some ideas and solutions!

Wireless Info tool output http://pastebin.com/Dd7igCqb

root@pink-fluffy-unicorn:~# uname -v
#1 SMP Debian 3.16.7-ckt20-1+deb8u3 (2016-01-17)


root@pink-fluffy-unicorn:~# lspci | grep Network
04:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8812AE 802.11ac PCIe Wireless Network Adapter (rev 01)


root@pink-fluffy-unicorn:~# apt-get install firmware-realtek
Reading package lists... Done
Building dependency tree       
Reading state information... Done
firmware-realtek is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


root@pink-fluffy-unicorn:~# modprobe rtl8821ae
root@pink-fluffy-unicorn:~#


root@pink-fluffy-unicorn:~# iwconfig
eth0      no wireless extensions.

wlan0     IEEE 802.11abgn  ESSID:"WLAN-927602"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 94:4A:0C:DF:A5:BB   
          Bit Rate=1 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=62/70  Signal level=-48 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

lo        no wireless extensions.

journalctl -u NetworkManager http://pastebin.com/4zzbMxcC

journalctl -u wpa_supplicant http://pastebin.com/1MPx03fj

journalctl -k http://pastebin.com/JAvM9gDy

Updates:

Following the suggestion from GAD3R I tried to disable power management using iwconfig with the following results:

root@pink-fluffy-unicorn:~# iwconfig wlan0 power off
Error for wireless request "Set Power Management" (8B2C) :
    SET failed on device wlan0 ; Operation not supported.

I then enabled power management using modprobe rtl8821ae swlps=1 to power management and then ran iwconfig wlan0 power off again, which executed without error. I then confirmed that power management was disabled using iwconfig wlan0 and monitored the output from journalctl -f. There did not appear to be any change from the altered configuration (I also tried iwconfig wlan0 power on to see if there was any change/improvement but it did not appear to have any significant impact)

0

You need to disable power management

iwconfig wlan0 power off

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.