This question already has an answer here:

I have a file that does exist but won't execute. It says : "No such file or directory".

This file is created by a script while creating a "custom toolchain" to compile native libraries for Android using the NDK.

I'm certain that the file exists where I beleive it exists. Also file says : arm-linux-androideabi-g++: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.8, stripped

I tried running as root, I also tried applying chmod 777, but nothing helped.

The file is located at : /tmp/my-android-toolchain/bin/arm-linux-androideabi-g++

It won't run even if I specify a full path, even if I copy it somewhere else (like in my home folder).

ldd says it's not a dynamic executable.

Maybe that this file is just a .so and not an actual executable with an entry point ?

I'm using Ubuntu 14, 64 bit, in a virtual machine.

marked as duplicate by terdon Feb 3 '16 at 17:07

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.


I found the solution in the comments of this question : When executable files aren't

It was a 32 / 64 bit problem.

When executable files aren't

fixed it.

Not the answer you're looking for? Browse other questions tagged or ask your own question.