0

I tried to update a server over SSH, but when I ran yum check-update I got an error:

[error 5] Input/output error

I think this means the RPM libraries may be damaged or corrupt, but I'm not sure how to resolve this.

  • This means (as its name implies) you have an error with your disk. There is an I/O error. – Valentin Bajrami Feb 2 '16 at 18:19
  • It also may mean that the yum cache location is not writable. Have you done any chmod's to /var recently? – Tim S. Feb 2 '16 at 18:22
0

As the comments mentioned its probably that there is something wrong with your disk. My first thought would be to check disk space. Double check file system too (btrfs snaps for example).

df -h

Then going into File permissions (chmod etc), and actual disk failures. Try to write or touch files in other directories/partitions

touch ~/yayfile.txt
touch /yayfile.txt
  • hi, thank you everyone for you help, i am still learning linux, so i really appreciate the assistance – user2513528 Feb 6 '16 at 3:34
  • Aren't we all :). Mark answered or comment ( if still need help ). – Dishcandanty Feb 13 '16 at 20:39
0

I ran into this same issue across a number of VMs. The fix that worked for me was to clean up yum tmp files.

yum clean all

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.