0

I just built a new computer and installed centos7 (RHEL based) and I also tried mint 17.3 (Ubuntu based). Installation goes without any problems. The operating system runs smooth and everything is quick for hours and then locks up. I can duplicate the problem by opening multiple instances of firefox, chrome, timeshift, vmware workstation, disks utility, etc and keep toggling my 3D desktop and eventually it freezes. I can't even ssh into it from another computer. If I don't try to duplicate the issue, i can be running firefox and 2 or 3 tabs and it freezes after hours of use.

I always have the top command running in terminal when on this machine. The most recent freeze, the CPU percentage of the top 4 apps are 52, 37, 21 and 10%, with ram usage for them at 2.0, 0.8, 0.8 and 0.4% respectively. Each time it has crashed the top apps have been different but usage has been roughly the same. CPU temp sits between 42-47 C in a room with ambient temperature of 21-23 C (AMD said the temps were good). Nothing extreme.

When it freezes, the system won't respond to Ctrl+Alt+F1, Ctrl+Alt+Backspace or Ctrl+Alt+Del. It also is not available via ssh from another computer on the network...doesn't even show up on the network when frozen. I hard reboot to get back in.

What I have tried:
Re-installing different versions of Linux
Resetting Motherboard (has current bios version)
Testing RAM with memtest86
Testing and swapping power supply
Downloaded and installed proprietary nvidia driver
Looked at this post for ideas

At this point I'm doing all my troubleshooting in mint 17.3 and watching output with:

top  

and

tail -f /var/log/{messages,kernel,dmesg,syslog}

Is there anything else I can do at the kernel level to try and troubleshoot/track down the problem?

Hardware:
ASUS M5 A97 R2.0 Motherboard
AMD FX 8320 8 core 3.5GHz cpu
Nvidia Geforce GT 730
2x8GB of Kingston Hyperx 1866 DDR3 RAM
250GB Samsung SSD 850 EVO
1000Watt 80+Gold Powersupply (Not needed but have for expansion ability...current system wattage ~280w and EVGA support said using high watt PS with low wattage system is inefficient but isn't issue.)

  • The times I've had problems that feel like yours, it's been either (a) bad memory stick or (b) video drivers. I have had memory sticks that passed memtest86, but would crash Linux within a few hours. The open source Nvidia drivers are supposed to be really good, aren't they? I also have a superstitious fear of cables. Are the cables all well-seated? Any ribbon cables? Those things go bad at inopportune times. – Bruce Ediger Feb 2 '16 at 3:49
  • Hey Bruce, all hardware is new (case, cables for monitors, etc). I did do a triple check on the cables because last week when I first put this system together, the power supply blew 21 min after turning the system on while it was sitting in bios. Tested and +12 rail was blown. EVGA support thought just a faulty ps, someone else told me it could have been a bad ground or loose cable (fully modular ps). I replace ps. I had the open source video drivers to begin with. I switched to proprietary to see if sys improved. I may end up doing a 10+ pass memtest as last resort. But it will take 2+ days. – jtlindsey Feb 2 '16 at 3:58
  • I suggest another problem source: the power supply. I once had similar problems with a dedicated server. After watching it for a while, and restarting frequently, i noticed that it always stopped under stress. Memmory tests etc. did not deliver any clue. So i added hardware sensor monitoring, and detected extreme high temperatures on one sensor. As i talked to the provider, asking for a check, they noticed that the power supply was broken, creating undeterministic power glitches, which lead to a system freeze. Maybe you have another powersupply at hand for testing ? – gerhard d. Feb 2 '16 at 8:24
  • I removed a 600w ps from another computer and it had the same problem after a few hours of running. The last thing I have changed right now is removing the open source drivers and installing the proprietary nvidia drivers. The system has been up for 8.5 hours now running multiple programs without any issues. If it doesn't crash within 24 hours, I'm going to guess it was the video card drivers. It was crashing 2 or more times a day originally. – jtlindsey Feb 2 '16 at 13:21
0

I agree with Bruce, first, the easiest - by no means the fastest way is to reinstall the NVidia drivers. Assuming you're running Mint

sudo apt-get remove --purge nvidia*

Then whereis nvidia

If any files still appear, delete them.

Then reinstall the nvidia drivers

To check for memory problems:

Remove all but one stick, reboot and let the computer run. Replace and check every stick, one at a time. If you have a bad stick you'll easily - but not quickly - find out.

If you still have the problem, there are a myriad of steps that can be done, but unfortunately now you'll have to start spending money - replace the cables, try another power supply, among othees.

  • I think the original nvidia drivers might be the problem. I uninstalled and reinstalled the drivers twice and the OS many times. The last thing I did was from my original post: remove the open source drivers and install the proprietary drivers straight from nvidia website. See my last comment under original post for details. Fingers crossed. – jtlindsey Feb 2 '16 at 13:25
0

According to top, it's been 2days, 1hr and 46min since the last change (I made change, rebooted and launched top command). Its been running everything from virtualbox (installing and running Linux guest) to vmware workstation (running windows and Linux mint guest and installing more Linux guest), timeshift, multiple browsers (chrome, firefox with many tabs), toggling 3d cube desktop, running steam, etc and the system hasn't frozen. CPU has reached over 200% (it's an 8 core so it can see 800%) with some of the multitasking I've been doing.

The last change was removing the ubuntu nvidia drivers for the graphics card and installing the proprietary drivers directly from the nvidia site using their instructions. I did this as a last ditch effort before my original post, not expecting it to work given the number of threads i read that said the open source drivers worked great for this and similar cards.

It looks like this time it was the graphics drivers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.