2

I am trying to connect an LG VL600 USB 4G Modem from Verizon on a Debian based machine (tried on Linux Mint and Raspberry Pi). I got it working on Windows 7 Virtualbox VM, so I know the device and service is working.

Device ID is 1004:61aa.

When I plug it in, I get a tty device /dev/ttyACM0 but wvdial gets no response and the device just flashes blue. When I connected it in Windows, it changed to green.

Has anyone gotten this to work?

I tried the Python scripts from here, but they didn't work. Is the kernel patch still needed on newer kernels (that patch is from 5 years ago)?


Kernel versions:

  • Raspberry Pi (Raspbian): 4.1.13-v7+
  • Desktop (Linux Mint 17.3): 3.19.0-32-generic

Output from wvdialconf:

Scanning your serial ports for a modem.

ttyACM0<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyACM0<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud
ttyACM0<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.


Sorry, no modem was detected!  Is it in use by another program?
Did you configure it properly with setserial?

Please read the FAQ at http://alumnit.ca/wiki/?WvDial

Any assistance would be highly appreciated. I have spent 2 days googling this and gotten nowhere.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.