0

I just changed my keyboard to an Ergodox with a US layout (previously it was Portuguese)

I use Arch Linux with Gnome 3, so I went to the settings manager, and added US as the default keyboard layout. As it turns out, that didn't work

If I set the current layout as PT, it all works as expected. When I change it to US though, everything is messed up. Here's the output of me pressing Shift-2 for a couple of seconds:

"""@@"@@@""""@@""@"@@""@@"@"""@@""@""@@"@@@""""@"@""@

As you can see, something is conflicting with the definition of the current layout. I cant at any point have a fully US keyboard. I either have full PT, or just a mix that changes randomly

Again, this is only a problem outside of my terminal, where I can fix it with setxkbmap us.

I have tried setting this option in xinitrc, but that didn't work either

EDIT:

After some more debugging, I noticed this is probably cause by either tmux or X11. The way I reproduce this:

  1. Add the PT layout on Gnome Settings.
  2. Remove the PT layout again, leaving only US
  3. At this point, Chrome, Sublime and all regular apps seem to be stable at US layout
  4. Alt-tab to a tmux window. It is still in US layout
  5. Alt-tab back out. Now everything is in PT layout
0

I ended up fixing this just now. I tried temporarily renaming my ~/.config directory so that it wasn't found. And that seemed to fix it. I then handpicked some of the config subdirectories I wanted to keep, copied those over to the newly created .config directory, and made sure everything was still working properly

I lost some useful configs, but at least now whatever was messing up my keyboard layout is gone for good.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.