I’m brand new to linux and, coming from Windows, I sometimes find it quite daunting. I managed to install openSUSE and after much trial and error I discovered how to install some software, and my video driver with YaST.

My problem is that when I try to play Flash games in Firefox or Chrome they flicker sporadically and Flash videos play like a slide-show. Occasionally my system hangs for approximately 5–10 minutes in full screen mode. I have no idea what’s wrong. Is it Flash or the nVidia driver?

I’ve searched the web for possible solutions and the closest I came was this forum post. At the end of the thread, the poster writes:

I revert to [nVidia] 280.13 and now it is working well, I will wait to new fixes.

Unfortunately, I don't know how to install an older version of the driver (or if it will fix my problem if I do).

Please bare in mind that I’ve only been using openSUSE for about a week.

CPU Information

Processor (CPU):    Intel(R) Celeron(R)
CPU 2.40GHz Speed:  2,399.96 MHz

Memory Information

Total memory (RAM): 969.9
MiB Free memory:    85.4 MiB (+ 321.4 MiB Caches)
Free swap:          637.2 MiB

OS Information

OS:                 Linux 3.1.0-1.2-default i686
System:             openSUSE 12.1 (i586)
KDE:                4.7.2 (4.7.2) "release 5"

Display Info

Vendor:             nVidia Corporation
Model:              GeForce 6200 (0x0221)
2D driver:          nvidia
3D driver:          NVIDIA 290.10


This problem occurs primarily with Facebook games and certain video websites. Youtube, Dailymotion, and Hulu perform well, but less known sites such as wimp.com or funnyordie.com perform poorly. I don’t expect high definition video to perform very well since I only have 1GB of RAM, but most of these sites stream low quality video.

I should add that I didn’t experience any problems under Ubunutu 11.10 so I’m wondering if this is related to openSUSE or possibly KDE.

  • I tried removing flash and installing gnash, but gnash didn't work at all.
    – Herbert
    Commented Dec 4, 2011 at 8:35
  • 1
    Consider trying chromium instead of chrome. While they are similar, flash in chromium is more stable in my experience. Disclaimer, I use chromium in Debian, not opensuse. Commented Dec 4, 2011 at 9:12
  • @FaheemMitha: thx for the tip. i removed chrome and installed chromium. It didn't solve my problem, but the browser seems to respond better overall. It also has more sensible defaults, e.g. showing the "home" button without having to select it in preferences.
    – Herbert
    Commented Dec 4, 2011 at 19:30
  • How did you get your display info? For the record, I'm using 195.36.31-6 (Debian). I see that 290.10-1 is the version currently in Debian unstable. My card is the GeForce 7300 GS. I'd suggest either trying a downgrade, or try an open source driver like Nouveau as tjbp suggested. If you need help downgrading the driver, I'd suggest opening another questions. Asking on an opensuse specific forum might be more productive. Alternatively, try another distribution. Commented Dec 4, 2011 at 20:16
  • 1
    Look at older releases of opensuse for older versions of the nvidia driver? Even if you do find something suitable, you are not out of the woods, because it is unlikely to install without some tweaking. BTW, congrats on supplying very complete information on the problem. It is unfortunately rare. Commented Dec 4, 2011 at 21:34

5 Answers 5


In my experience the proprietary linux driver that nvidia offers can cause terrible performance issues with certain cards (especially older ones). The person that resolved their problem by reverting their driver to an older version is a good demonstration of the nvidia driver's regression problems.

I'd recommend trying the open source nvidia driver known as "nouveau". It doesn't always work flawlessly with less-popular cards (I've had complete failures to load with obscure nvidia cards like the 7300GS), and afaik it can't handle 3D acceleration thanks to nvidia's lack of communication, but in most cases it can be a great performer for normal desktop usage.

I'm not hugely familiar with openSUSE's packaging system, but you'll probably have to remove the nvidia package before installing nouveau. If not, you'll need to blacklist the nvidia module (prevent it from loading) by adding the module's name to /etc/modprobe.d/blacklist.conf (in this case blacklist nvidia) and then reboot.

You can check which module is currently loaded in a terminal using lsmod | grep nvidia, or for nouveau lsmod | grep nouveau.

  • I tried everything you suggested with no luck, but researching how to do what you suggested lead me to some more resources so +1 for that.
    – Herbert
    Commented Dec 5, 2011 at 1:39

Although I have some experience with OpenSUSE ( and am running 12.1 with the latest Yast NVidia driver ) I don't know enough to advise here, other than recommending the OpenSUSE forums; and suggesting in yast to search for flash, and then to eliminate the pullin-flash-player ( which is unneeded, and I put a lock on saying never install ). This usually solves my flash problems ( but I'm using 64bit ).

Failing that you might try reinstalling Adobe Flash in yast ( check update ) or removing it completely and trying a substitute from yast, such as Gnash.

In the meantime, I hope you installed all codecs etc., using this excellent guide from the forums. 12.1 is the last post, and all you need from the thread.


  • Thanks for taking the time to answer. I eliminated the pullin-flash-player and installed all codecs to no avail. The opensuse forum requires far too much personal info just to create an account. I'll stick with Stack Exchange and hope for the best. :)
    – Herbert
    Commented Dec 3, 2011 at 23:21

I would also suggest trying the nouveau driver for nvidia cards, but don't know if it will be an improvement.
The problem is that Adobe Flash and nvidia combined spell trouble for Linux users. Try also disabling desktop effects like "blur", or turn them all off (in case you use KDE).

  • I've tried nouveau with no luck. Disabling desktop effects in KDE help somewhat. I think it primarily has to do with the fact that I only have 1GB of RAM installed. After all the research I've done though, I have to agree with you that "Adobe Flash and nvidia combined spell trouble for Linux users".
    – Herbert
    Commented Jan 4, 2012 at 22:37


  1. overheating caused by Flash Player http://forums.adobe.com/thread/487472
  2. an impressive amount of dust accumulated in the micro heat sink that makes things worse


  • System shutdown automatically due to overheat


  • Clean the micro heat sink fixed this problem.

In may case when playing flash videos from youtube or similar pages, my system shut itself down after 3 minutes of play. It only happens with flash movies played with the Adobe flash plugin from a web browser (Firefox or Chrome).


Opensuse 11.4 i586
AMD Athlon X2
GeForce 6100 nForce 405
  • 1
    My system isn't shutting down; however, I was having an overheating problem that cleaning the heat sink fixed. My problem is that Facebook games and videos from some websites play very slowly.
    – Herbert
    Commented Jan 4, 2012 at 22:32

Hey this is a Video consumption problen with firefox adobe package container This can be disabled in about:config... search.. dom.ipc .... disable plugin

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .