I have read all over the Internet about changing text files or running commands to change my wm but none of them work. I have looked all around the gnome lock screen for a button allowing me to change my wm but I could find none. I have installed and uninstalled i3 multiple times but I cannot get it to run. Is anyone able to help?

  • How do you log in? Assuming you use a graphical login manager, did you try selecting i3 at the login screen? If that's what you mean by "lock screen", please edit and tell us which one you are using. GDM? MDM? LightDM? KDM? Something else?
    – terdon
    Jan 31, 2016 at 17:43

1 Answer 1


The best way to get i3 installed and running from a Gnome3 Desktop is, first to install i3:

apt-get install i3

Other packages may also be useful:

apt-get install feh xautolock xbacklight

Then, in the gdm3 after selecting a user, just choose the i3 desktop.

My advice is to keep as much from your GNOME desktop. For this, just add the following in your ~/.config/i3/config file:

# audio controls
bindsym XF86AudioRaiseVolume exec --no-startup-id pactl set-sink-volume 1 +5%
bindsym XF86AudioLowerVolume exec --no-startup-id pactl set-sink-volume 1 -5%
bindsym XF86AudioMute exec --no-startup-id pactl set-sink-mute 1 toggle

# screen brightness controls
bindsym XF86MonBrightnessUp exec xbacklight -inc 10
bindsym XF86MonBrightnessDown exec xbacklight -dec 10

# screenlock
bindsym Control+Mod1+l exec gnome-screensaver-command -l

# custom settings
exec --no-startup-id gnome-session         # GNOME session
exec --no-startup-id gnome-settings-daemon # GNOME desktop settings
exec --no-startup-id gnome-screensaver     # GNOME screensaver
exec --no-startup-id xautolock -time 10 -locker 'gnome-screensaver-command -l'

# background image
exec --no-startup-id feh --bg-fill /path/to/background.png

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .