0

I've recently started encountering this problem that my system takes too long to start and also to shut down. I searched it and found that dmesg shows the logs of processes at boot time. Here's my log from dmesg. I've clipped the logs to cut it short. Processes that I clipped seems to be working fine but here's where the problem arises. Any suggestion?

siera@Cybotron:~$ dmesg
[    1.540147] tsc: Refined TSC clocksource calibration: 1696.073 MHz
[    2.003598] EXT4-fs (sda3): mounted filesystem with ordered data mode. Opts: (null)
[    2.540612] Switched to clocksource tsc
[    2.596531] random: init urandom read with 115 bits of entropy available
[    2.774045] random: nonblocking pool is initialized
[   12.885594] systemd-udevd[292]: starting version 204
[   12.977348] lp: driver loaded but no devices found
[   12.985470] ppdev: user-space parallel port driver
[   13.034744] hidraw: raw HID events driver (C) Jiri Kosina
[   13.038293] [drm] Initialized drm 1.1.0 20060810
[   13.065904] dw_dmac INTL9C60:00: DesignWare DMA Controller, 8 channels
[   13.085231] wmi: Mapper loaded
[   13.085489] mei_me 0000:00:16.0: irq 59 for MSI/MSI-X
[   13.090509] [drm] Memory usable by graphics device = 2048M
[   13.090514] [drm] Replacing VGA console driver
[   13.091734] Console: switching to colour dummy device 80x25
[   13.113041] i915 0000:00:02.0: irq 60 for MSI/MSI-X
[   13.113056] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[   13.113057] [drm] Driver supports precise vblank timestamp query.
[   13.113117] vgaarb: device changed decodes: PCI:0000:00:02.0,olddecodes=io+mem,decodes=io+mem:owns=io+mem
[   13.142974] [drm] seamless DRRS supported for eDP panel.
[   13.146930] AVX2 version of gcm_enc/dec engaged.
[   13.181861] fbcon: inteldrmfb (fb0) is primary device
[   13.189583] intel_rapl: Found RAPL domain package
[   13.189585] intel_rapl: Found RAPL domain core
[   13.189586] intel_rapl: Found RAPL domain uncore
[   13.189588] intel_rapl: Found RAPL domain dram
[   13.396405] EXT4-fs (sda3): re-mounted. Opts: errors=remount-ro
[   13.648429] Bluetooth: Core ver 2.19
[   13.648441] NET: Registered protocol family 31
[   13.648442] Bluetooth: HCI device and connection manager initialized
[   13.648448] Bluetooth: HCI socket layer initialized
[   13.648450] Bluetooth: L2CAP socket layer initialized
[   13.648458] Bluetooth: SCO socket layer initialized
[   13.651522] usbcore: registered new interface driver btusb
[   13.698489] FS-Cache: Loaded
[   13.705044] RPC: Registered named UNIX socket transport module.
[   13.705045] RPC: Registered udp transport module.
[   13.705045] RPC: Registered tcp transport module.
[   13.705045] RPC: Registered tcp NFSv4.1 backchannel transport module.
[   13.712364] FS-Cache: Netfs 'nfs' registered for caching
[   13.720024] bluetooth hci0: Direct firmware load failed with error -2
[   13.720025] bluetooth hci0: Falling back to user helper
[   13.722884] Installing knfsd (copyright (C) 1996 okir@monad.swb.de).
[   13.741688] dcdbas dcdbas: Dell Systems Management Base Driver (version 5.6.0-3.2)
[   14.269505] Console: switching to colour frame buffer device 170x48
[   14.272465] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[   14.272466] i915 0000:00:02.0: registered panic notifier
[   14.314026] [Firmware Bug]: ACPI(PEGP) defines _DOD but not _DOS
[   14.328219] input: Dell WMI hotkeys as /devices/virtual/input/input8
[   14.328940] hid-rmi 0018:06CB:2985.0001: Scanning PDT...
[   14.331631] hid-rmi 0018:06CB:2985.0001: Found F34 on page 0x00
[   14.333758] Bluetooth: hci0: BCM: patch brcm/BCM43142A0-0a5c-21d7.hcd not found
[   14.334242] hid-rmi 0018:06CB:2985.0001: Found F01 on page 0x00
[   14.336806] hid-rmi 0018:06CB:2985.0001: Found F11 on page 0x00
[   14.342825] hid-rmi 0018:06CB:2985.0001: Found F54 on page 0x01
[   14.345258] hid-rmi 0018:06CB:2985.0001: Found F30 on page 0x01
[   14.346798] ACPI: Video Device [PEGP] (multi-head: yes  rom: yes  post: no)
[   14.346869] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:08/LNXVIDEO:00/input/input9
[   14.348492] ACPI: Video Device [GFX0] (multi-head: yes  rom: no  post: no)
[   14.348582] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:01/input/input10
[   14.348675] [drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0
[   14.348978] snd_hda_intel 0000:00:1b.0: irq 61 for MSI/MSI-X
[   14.349050] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
[   14.351685] hid-rmi 0018:06CB:2985.0001: Found F55 on page 0x02
[   14.357559] snd_hda_intel 0000:00:03.0: irq 62 for MSI/MSI-X
[   14.358089] hid-rmi 0018:06CB:2985.0001: rmi_scan_pdt: Done with PDT scan.
[   14.364770] cfg80211: Calling CRDA to update world regulatory domain
[   14.370295] input: HDA Intel HDMI HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:03.0/sound/card0/input11
[   14.370388] input: HDA Intel HDMI HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:03.0/sound/card0/input12
[   14.370474] input: HDA Intel HDMI HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:03.0/sound/card0/input13
[   14.374100] hid-rmi 0018:06CB:2985.0001: rmi_populate_f11: size in mm: 102 x 57
[   14.384992] input: DLL0662:00 06CB:2985 as /devices/pci0000:00/INT33C3:00/i2c-1/i2c-DLL0662:00/0018:06CB:2985.0001/input/input7
[   14.385127] hid-rmi 0018:06CB:2985.0001: input,hidraw0: <UNKNOWN> HID v1.00 Mouse [DLL0662:00 06CB:2985] on 
[   14.397757] sound hdaudioC1D0: autoconfig: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
[   14.397761] sound hdaudioC1D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[   14.397762] sound hdaudioC1D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[   14.397763] sound hdaudioC1D0:    mono: mono_out=0x0
[   14.397765] sound hdaudioC1D0:    inputs:
[   14.397766] sound hdaudioC1D0:      Headset Mic=0x19
[   14.397768] sound hdaudioC1D0:      Headphone Mic=0x1a
[   14.397769] sound hdaudioC1D0:      Internal Mic=0x12
[   14.461851] cfg80211: World regulatory domain updated:
[   14.461855] cfg80211:  DFS Master region: unset
[   14.461856] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   14.461859] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[   14.461861] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[   14.461863] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm), (N/A)
[   14.461865] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[   14.461867] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[   14.481380] input: HDA Intel PCH Headphone Mic as /devices/pci0000:00/0000:00:1b.0/sound/card1/input14
[   14.552475] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   14.552480] Bluetooth: BNEP filters: protocol multicast
[   14.552490] Bluetooth: BNEP socket layer initialized
[   14.556264] Bluetooth: RFCOMM TTY layer initialized
[   14.556275] Bluetooth: RFCOMM socket layer initialized
[   14.556279] Bluetooth: RFCOMM ver 1.11
[   14.688385] audit: type=1400 audit(1454254759.588:2): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/cups/backend/cups-pdf" pid=632 comm="apparmor_parser"
[   14.688393] audit: type=1400 audit(1454254759.588:3): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/sbin/cupsd" pid=632 comm="apparmor_parser"
[   14.688839] audit: type=1400 audit(1454254759.588:4): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/sbin/dhclient" pid=661 comm="apparmor_parser"
[   14.688846] audit: type=1400 audit(1454254759.588:5): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/NetworkManager/nm-dhcp-client.action" pid=661 comm="apparmor_parser"
[   14.688851] audit: type=1400 audit(1454254759.588:6): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/connman/scripts/dhclient-script" pid=661 comm="apparmor_parser"
[   14.688910] audit: type=1400 audit(1454254759.588:7): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/sbin/cupsd" pid=632 comm="apparmor_parser"
[   14.689365] audit: type=1400 audit(1454254759.588:8): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/lib/NetworkManager/nm-dhcp-client.action" pid=661 comm="apparmor_parser"
[   14.689371] audit: type=1400 audit(1454254759.588:9): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/lib/connman/scripts/dhclient-script" pid=661 comm="apparmor_parser"
[   14.689601] audit: type=1400 audit(1454254759.592:10): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/lib/connman/scripts/dhclient-script" pid=661 comm="apparmor_parser"
[   14.692078] audit: type=1400 audit(1454254759.592:11): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/sbin/ntpd" pid=664 comm="apparmor_parser"
[   14.825776] [drm] Enabling RC6 states: RC6 on, RC6p off, RC6pp off
[   14.835700] init: failsafe main process (684) killed by TERM signal
[   14.903684] init: cups main process (665) killed by HUP signal
[   14.903692] init: cups main process ended, respawning
[   15.022962] init: Failed to obtain startpar-bridge instance: Unknown parameter: INSTANCE
[   15.645110] wl: module license 'MIXED/Proprietary' taints kernel.
[   15.645114] Disabling lock debugging due to kernel taint
[   15.647692] wl: module verification failed: signature and/or  required key missing - tainting kernel
[   15.778318] wlan0: Broadcom BCM4365 802.11 Hybrid Wireless Controller 6.30.223.248 (r487574)
[   16.660535] r8169 0000:07:00.0 eth0: link down
[   16.660578] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   21.475309] init: plymouth-upstart-bridge main process ended, respawning
[   22.921282] vboxdrv: Found 4 processor cores
[   22.941064] vboxdrv: TSC mode is Invariant, tentative frequency 1696033481 Hz
[   22.941067] vboxdrv: Successfully loaded version 5.0.2 (interface 0x00230003)
[   23.144285] VBoxNetFlt: Successfully started.
[   23.145769] VBoxNetAdp: Successfully started.
[   23.147745] VBoxPciLinuxInit
[   23.150634] vboxpci: IOMMU not found (not registered)
[   23.487391] init: plymouth-stop pre-start process (1657) terminated with status 1
[   38.151767] cfg80211: Calling CRDA for country: GB
[   38.153750] cfg80211: Regulatory domain changed to country: GB
[   38.153753] cfg80211:  DFS Master region: unset
[   38.153754] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   38.153756] cfg80211:   (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   38.153758] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   38.153759] cfg80211:   (5250000 KHz - 5330000 KHz @ 40000 KHz), (N/A, 2000 mBm), (0 s)
[   38.153760] cfg80211:   (5490000 KHz - 5710000 KHz @ 40000 KHz), (N/A, 2700 mBm), (0 s)
[   38.153761] cfg80211:   (57240000 KHz - 65880000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A)
[   44.771234] audit_printk_skb: 141 callbacks suppressed
[   44.771237] audit: type=1400 audit(1454254789.657:59): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/lib/cups/backend/cups-pdf" pid=2369 comm="apparmor_parser"
[   44.771243] audit: type=1400 audit(1454254789.657:60): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/sbin/cupsd" pid=2369 comm="apparmor_parser"
[   44.771558] audit: type=1400 audit(1454254789.657:61): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/sbin/cupsd" pid=2369 comm="apparmor_parser"
siera@Cybotron:~$ 
  • That doesn't really give us much. dmesg is only kernel messages, and your problem likely isn't with the kernel. Try rebooting to the grub prompt, select your boot option, press 'e' to edit, and add init=/bin/bash to the kernel parameters. If you get a shell quickly, then it's the userland, not the kernel, that is the problem. Try using systemctl --failed and journalctl to troubleshoot from there. – Jeff Spaulding Jan 31 '16 at 18:48
  • Just to be clear, you should add that to the line that starts with linux. – Jeff Spaulding Jan 31 '16 at 19:15
  • @JeffSpaulding : I got the shell almost immediately(about 2-3 seconds) but it displays some weird message before shell prompt. It says bash: Cannot set terminal process group(-1): Inappropriate ioctl for device bash: no job control in this shell and then the prompt itself looks weird as it says root@(none):/# and further more when I typed reboot it said Shutdown: Unable to shutdown system. – 7_R3X Feb 1 '16 at 16:36
  • That's normal. To shut down the system, do mount -o remount,ro /, wait a few seconds, and then shut off the system. What this tells us is that it's not the kernel that is the problem - it's something that starts after the kernel. Check the systemctl and journalctl commands and see if anything is failing. – Jeff Spaulding Feb 1 '16 at 18:13
  • @JeffSpaulding There isn't a command like systemctl or journalctl. – 7_R3X Feb 1 '16 at 18:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.