1

I've been spinning my head for 2 hours now trying to understand how yum goes through a repo. I'm getting a very strange behavior.

Some background:

  • Local epel-7 CentOS repo on repo server
  • The repo was created using reposync (reposync, createrepo, repomanage)
  • I can see the repo fine using http://local.reposerver/epel-7-x86_64/
  • I can also see the files using a shell on repo server
  • The client is configured and has network access to repo

Epel-7 repository structure is a little different than Epel-6 structure. It looks like this:

tree -d
.
├── 0
├── 2
├── 3
├── a
├── b
├── c
├── d
├── e
├── f
├── g
├── h
├── i
├── j
├── k
├── l
├── m
├── n
├── o
├── p
├── q
├── r
├── repodata
├── s
├── t
├── u
├── v
├── w
├── x
├── y
└── z

30 directories

With all the packages under their respective letters/numbers

I'm saying this because the heart of my problem is that when I do a:

yum --disablerepo="*" --enablerepo="epel-7" list available

I get all the packages except the l directory and everything under it.

I've tried clearing everything:

yum clean all

I've tried deleting the repodata on the repo server and recreated it but nothing works.

That is why I am trying to understand the internals of the yum search command. What files/data bases does it call, so I can find which one is corrupted/broken?

Could it be cache on the http server side?

  • have you done your yum update? – Rui F Ribeiro Jan 29 '16 at 9:29
  • this is a vagrant box of centos 7 with the latest DVD iso so No packages marked for update (since it goes against my local repo created with the same iso). This is really strange.... just did a rm -rf /var/lib/rpm/__db* && rpm --rebuilddb and same behavior... weird. – EBerth Jan 29 '16 at 9:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.