0

I'm running Linux Mint 17.3 and I can't install VLC. When I type in

sudo apt-get install vlc

This is the result I get:

Reading package lists... Done

Building dependency tree

Reading state information... Done

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: vlc : Depends: vlc-nox (= 2.2.1-3~ubuntu14.04.1~c42.ppa1) but it is not going to be installed Depends: libstdc++6 (>= 4.9) but 4.8.4-2ubuntu1~14.04 is to be installed E: Unable to correct problems, you have held broken packages.

Any idea how to resolve this?

  • Please post the output of apt-cache policy and apt-cache policy vlc vlc-nox libstdc++6 into the question. – Faheem Mitha Jan 29 '16 at 0:18
-1

If you have APT/Dpkg package version mismatches, it may mean a bad formed /etc/apt/sources.list. Check if it uses distro upstream. Change all lines like:

deb http://tralalala.xxxxxxxx.com/lol ffff main contrib non-free

to

deb http://tralalala.xxxxxxxx.com/lol upstream main contrib non-free

You don't have to change deb-src lines. After updating the sources.list file, run sudo apt-get update. Then try installing VLC again.

0

Install synaptic pachage manager and fix broken packages

1) Add ppa and install vlc

sudo add-apt-repository ppa:videolan/stable-daily
sudo apt-get update
sudo apt-get install vlc

2) Or Check Dependencies and install vlc

 sudo apt-cache showpkg vlc

to build dependencies

 sudo apt-get build-dep vlc

then install it

3) you can inslall vlc from package manager

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.