3

I am running the Debian 8.0 64bit (Jessie, the stable release) on my HP laptop. I am having hard time in installing the proprietary nVidia driver of my graphic card

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF108M [GeForce GT 630M] [10de:0de9] (rev ff)

I have followed step by step the guides on debian wiki. Bumblebee is required since my graphic card comes with nvidia optimus. So far so good, I think I have all the right packages required on my machine. Now I have to enable bumblebee. It turns out the right command is

sudo optirun nvidia-settings -c :8

So a graphic front-end appears, I leave all the defaul checks and I have just to save the configuration file in the /etc/X11 folder as xorg.conf. But at the system restart I get the black screen and x can't start, it says that there are "No screens found". Here it is the log

[    74.012] (II) xfree86: Adding drm device (/dev/dri/card0)

[ 74.014] (--) PCI:*(0:0:2:0) 8086:0126:103c:181d rev 9, Mem @ 0xd4000000/4194304, 0xc0000000/268435456, I/O @ 0x000050$ [ 74.014] (II) LoadModule: "glx" [ 74.015] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so [ 74.017] (II) Module glx: vendor="X.Org Foundation" [ 74.017] compiled for 1.16.4, module version = 1.0.0 [ 74.017] ABI class: X.Org Server Extension, version 8.0 [ 74.017] (==) AIGLX enabled [ 74.017] (II) LoadModule: "nvidia" [ 74.017] (WW) Warning, couldn't open module nvidia [ 74.017] (II) UnloadModule: "nvidia" [ 74.017] (II) Unloading nvidia [ 74.018] (EE) Failed to load module "nvidia" (module does not exist, 0) [ 74.018] (EE) No drivers available. [ 74.018] (EE) Fatal server error: [ 74.018] (EE) no screens found(EE) [ 74.018] (EE) Please consult the The X.Org Foundation support at .... for help. [ 74.018] (EE) Please also check the log file at "/home/zarathushtra/.local/share/xorg/Xorg.0.log" for additional infor$ [ 74.018] (EE)

(sorry for horrible formatting)

Anyone?

Thanks!

1

Just use Bumblebee

I too was misguided by the 'You don't seem to be using the nvidia driver' message the nvidia settings GUI gave me, so I tried to run nvidia-xconfig. Don't run the nvidia-xconfig tool or it will leave you with no X server at next reboot.

Hopefully you can step back by removing /etc/X11/xorg.conf

Because this is what happened to me: I thought the installation of Bumblebee wasn't complete, and I needed to enable the nvidia driver. And then, as I rebooted, I stumbled upon the exact same error you had: X server crashed, because no screens were found.

It seems this is because optimus technology prevents direct display rendering (from the Bumblebee FAQ).

So you've actually found the answer yourself, and it's bumblebee.

You don't need to do anything with the nvidia-driver. Bumblebee will automatically pull it in for you, and use it when you need it. All you need to do is call optirun with the program you need to launch on the graphics card.

Everything else is handled by the CPU, and that's for the best because bumblebee turns off the graphics card when it's not used, meaning energy savings combined with on-demand performances, and that's the point of the optimus technology.

All credit goes to allicoder for his research on his answer

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.