3

How can this be achieved? I want to boot the headless Ubuntu 14.04 box and have it start TightVNC as root.

  • That does not start the server on Ubuntu 14.04, which uses Upstart @GAD3R – user12a Jan 28 '16 at 15:19
2

Sorry if this is too late. Put this in /lib/systemd/system/x11vnc.service:

[Unit]
Description=Start x11vnc at startup.
After=multi-user.target

[Service]
Type=simple
ExecStart=/usr/bin/x11vnc -auth guess -forever -loop -noxdamage -repeat -rfbauth /home/USERNAME/.vnc/passwd -rfbport 5900 -shared

[Install]
WantedBy=multi-user.target

Replacing "USERNAME" with your username.

Then do sudo systemctl daemon-reload and sudo systemctl enable x11vnc.service. I think it will start on the next boot.

(Source)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.